Lag spikes/jump spikes since the latest patch

Comment below rating threshold, click here to show it.

Wimex

Junior Member

01-21-2013

Since the release of Kayle's Legendary skin, playing games have become very hard for me, even for easy bots. This has never happened to me before, but when I updated and had a game, I've been getting jump spikes/lag spikes throughout the games. Not only that but I've been disconnecting multiple times.

I get invalid minions and I die a few times because the screen freezes, and when it stops, I see that I died. I can even control my champion for a few seconds after I died because of the spikes.

I've uninstalled the game, and reinstalled it according to the reinstall thread and I still lag. I also noticed that the gold in the marketplace has also be going funny on me. A couple of games ago when we started, I only brought one pair of boots, and one health pot and somehow my gold ended up -295.

Ping: 186(I live in Australia and this has always been my ping. Works perfectly with me all the time. I've also been keeping track of it through out the games and it's been pretty damn steady)
FPS:60

I was curious to see if this was happening to anyone else, and if there is anyway to fix this problem.


Comment below rating threshold, click here to show it.

CYSL

Junior Member

01-21-2013

same issue!


Comment below rating threshold, click here to show it.

JashMashMcGash

Junior Member

01-21-2013

bump


Comment below rating threshold, click here to show it.

Wimex

Junior Member

01-21-2013

Bump.


Comment below rating threshold, click here to show it.

Wimex

Junior Member

01-22-2013

Bump.