Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


Lags and low FPS the last patch has it all

1
Comment below rating threshold, click here to show it.

blck3on

Recruiter

01-19-2013

Since the last patch came in it has literally stopped me from playing League. Here is the list of bugs that i found.

1. low FPS during game.
Usually i get good average 30-40 FPS, since the last patch its below 20 FPS

2.Constant lag
I never lagged before, in fact i didn't experience lag until the patch came out.

3.Reconnecting the game doesn't work
When it started lagging i tried reconnecting the game but it gets stuck at 100% and if i minimise it, it disconnects me from the game.

4.Leaves are not recorded
Not sure if this is a real bug but my last game was a leave due to lag and low FPS but when i logged in again it did not mark the game as leave but as a win(we were winning so i guess its true)

Note: I had my Avast anti-virus so it might had to do something with that, but i never had this problem before.


Comment below rating threshold, click here to show it.

FreshToDeathNz

Junior Member

01-19-2013

im experiencing the same, is there a fix? i got 60fps before patch now im at about 40 and randomly drop down to 10-15 used to play on high graphics and now on very low with still lag, riot please fix !


Comment below rating threshold, click here to show it.

Shopkeeper

Member

01-19-2013

I'm having similar issues that have started since the latest patch. Every now and then I'll either temporarily disconnect from the game (the auto reconnect takes care of this ~20 seconds), or I'll get a weird form of lag- health bars, skills, and champions aren't on screen at the time stop showing up, but I'm able to move, cast spells, and watch the movement of allies/onscreen enemies until the game "catches up". I've experienced this issue on both my desktop and laptop; I'm running windows 7 on both machines for reference.


Comment below rating threshold, click here to show it.

midixienormous

Junior Member

01-21-2013

I have had the same issue, before the patch I avg 60 fps on high resolution setting, after the patch at times I get as low as 2 to 3 fps on low resolution setting.


Comment below rating threshold, click here to show it.

Aesmis

Senior Member

01-21-2013

I know a lot of people who've been dealing with the same stuff.


Comment below rating threshold, click here to show it.

Botchlaa

Member

02-02-2013

bump. fps issues.


Comment below rating threshold, click here to show it.

Abelas

Member

02-02-2013

Yeah, I'm getting random disconnects in game, having all my actions delayed, and having everything around me freeze then suddenly catch up. Most of the time when I freeze up I can still see everybody else moving. It's also been causing my ping to spike up to as high as 15k. Being in NZ might help with the whole ping thing but this is ridiculous.


Comment below rating threshold, click here to show it.

Cheesebeard

Senior Member

02-02-2013

Yar, same here -- very bad graphical latency and jitters since the S3 patch this week. Teamfights are especially brutal (dropping FPS significantly), and there were no hardware, software, or connection changes since before the patch.

FTR I'm running Win7, GeForce 9600 GT (newest driver, 310.90)


1