Radeon cards experiencing flicker with new patch

First Riot Post
Comment below rating threshold, click here to show it.

Gabber

This user has referred a friend to League of Legends, click for more information

Recruiter

01-18-2013

Quote:
Originally Posted by MyFatalFlaw View Post
EternalStealth, here is the problem. You have a graphics card built by AMD that is utilizing the PCIe 3.0 architecture. You have a motherboard that does not have a PCIe 3.0 slot. Instead you are using a PCIe 2.0 or 2.1 slot. Are you with me so far?

The AMD drivers, are causing issues with backward compatibility. Riot is a video game manufacture that creates a game that SHOULD be playable on a computer that meets the minimum system requirements.

You are trying to use logic to place blame on Riot with

League before patch = perfectly fine
League after patch = getting this issue

This is a logic fallacy. Correlation is not causation my friend. it is people like you who exhibit persistent obstinence in laying the blame on Riot instead of accepting that the video card drivers that you are using are the root cause.

Before update to beta drivers = graphical glitches
After updating to beta drivers = no graphical glitches.

I have responded to you before with your 3 options if you do not want to use beta drivers. Buy a new motherboard that has a PCIe 3.0 slot, get a graphics card that uses the PCIe 2.0/2.1 architecture, or stop playing LOL. You continue to complain instead of fix the problem that lies INSIDE YOUR COMPUTER

Running a Radeon HD 7970 video card with MSI Z77A-g43 motherboard, which has a PCIe 3.0 slot and I have the exact same problem. That's not the problem.


Comment below rating threshold, click here to show it.

Disturd

Recruiter

01-18-2013

Download the 13.1 for amd R7850 and it helps a bit but still happening! Please fix it!


Comment below rating threshold, click here to show it.

Zimmy

This user has referred a friend to League of Legends, click for more information

Member

01-18-2013

Yep I have the problem to im using radeon hd xfx 7870


Comment below rating threshold, click here to show it.

ShivaInn

This user has referred a friend to League of Legends, click for more information

Junior Member

01-18-2013

I'm using a 7870.
I had same problem.
But, I just installed this beta driver, It has been fixed.

http://support.amd.com/us/kbarticles...etadriver.aspx


Comment below rating threshold, click here to show it.

Pardexxx

Junior Member

01-18-2013

Same problem here. I'm using an ASUS 7870.
I updated to 13.1 but still happening. The frequency of the flickering is lower but still exists.


Comment below rating threshold, click here to show it.

NewEdge

Member

01-18-2013

I have Sapphire 7770 and i'd like to report this problem as well. I thought it was my card failing at first. I still have 12.1.


Comment below rating threshold, click here to show it.

kerbnasty

Junior Member

01-18-2013

Using a 7970 on CCC 13.1 drivers; new patch worked last night on 12.11 drivers; was getting the flickering in games today after updating to 13.1; now the games bugsplat the second it transitions from lobby to loading screen.

Running a client repair; will post again if I get it fixed.

EDIT: Client repair did not work--bug splats at ever loading screen. Rolling back to 12.11 drivers.

EDIT2: Rolled back to 12.11 Beta 7 drivers; still getting bugsplats when the game hits loading screen.


Comment below rating threshold, click here to show it.

ICARU5

Junior Member

01-19-2013

how in gods name did you manage to screenshot this ****, it literally flashes on mine for a milisecond

7970 here
drivers up to date

i have this exact issue, hope for a fix soon


Comment below rating threshold, click here to show it.

Chiuy

Senior Member

01-19-2013

My drivers has the latest update and League of Legends still flickering from time to time. It would also give me black spots too in some of the area.

Specs:
Custom Built
- Intel i3570k
- ATI Radeon 7870 2GB
- 16GB Kingston Ram
- Z77 Asus Motherboard
- Intel SSD
- 23" ASUS Monitor

This flash is really annoying. Gives me headaches if it happens more than once in a 20 second time period.


Comment below rating threshold, click here to show it.

Disturd

Recruiter

01-19-2013

Quote:
Originally Posted by ShivaInn View Post
I'm using a 7870.
I had same problem.
But, I just installed this beta driver, It has been fixed.

http://support.amd.com/us/kbarticles...etadriver.aspx
I just don't want to download the beta drivers they should fix it.