Ashe ult not working

Comment below rating threshold, click here to show it.

Watafool

Senior Member

12-10-2012

Not really sure what happened or how to recreate it, but I was playing a game as Ashe earlier, and right before a big teamfight started, I tried to shoot my ult. Apparently it didn't want in on the fun.


I have my keybindings set to smart-cast with range indicators, so my first thought was that I was moving before I released, cancelling the activation. Then I tried standing perfectly still, and I tried it a few more times, still nothing happened. Finally right before I died, I pressed R, and left-clicked somewhere and it shot out.

Not sure why it locked up, or why clicking worked. I don't even know that the clicking actually did anything, or if it finally worked that time right when I clicked.

After I died I checked my keybindings, and it was still set to smartcast. I didn't have any other issues the rest of the game, and hadn't had any before that either. Not really sure what the problem was.