Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


Graphics bug after pre-season patch

Comment below rating threshold, click here to show it.

Ninja Boss91

Member

12-04-2012

most people won't have two cards, is it expected to be fixed in the near future or did this patch just screw a good amount of people


Comment below rating threshold, click here to show it.

CFlyHigh

Member

12-04-2012

alright so it seems that the problem is with the ATI Radeon series graphic cards, i have just downloaded the patch on my laptop which runs with an intel graphic card and there was no problem at all.


Comment below rating threshold, click here to show it.

Ninja Boss91

Member

12-04-2012

This is what i did with my hp pavilion laptop, right clicked destop went to graphics properties. With my laptop i can run intel, which they call power saving graphics(runs when not plugged in) or high performance (ati one when plugged into power supply) Within graphics properties i was able to switch to intel while still having my laptop plugged in, hope that helped at least someone


Comment below rating threshold, click here to show it.

Dillusionist

Junior Member

12-04-2012

disabling my non-intel graphics card solved the problem.


Comment below rating threshold, click here to show it.

Dannamoth

QA Analyst

Follow Dannamoth on Twitter

12-04-2012

Quote:
Ninja Boss91:
most people won't have two cards, is it expected to be fixed in the near future or did this patch just screw a good amount of people


This is a high priority fix. I just wanted to get a work around for the short term so you guys can play. I don't know when we will have a fix.


Comment below rating threshold, click here to show it.

RainbowSensation

Member

12-04-2012

Quote:
Ninja Boss91:
This is what i did with my hp pavilion laptop, right clicked destop went to graphics properties. With my laptop i can run intel, which they call power saving graphics(runs when not plugged in) or high performance (ati one when plugged into power supply) Within graphics properties i was able to switch to intel while still having my laptop plugged in, hope that helped at least someone


Yeah I'm able to do the same thing. Although it isn't really a permanent fix. Results in a fps loss and potential overheating of the laptop.
I might just lay off the LoL for a bit until this gets fixed and play Disgaea xD


Comment below rating threshold, click here to show it.

CFlyHigh

Member

12-04-2012

alright guys i have found a way to fix the problem.
what i did was install a driver update from AMD called AMD Catalyst and it somehow updated my graphic card and now i dont have the glitch anymore.

what you need to do to fix this :
1- you need to go on the AMD site
<http://support.amd.com/us/psearch/Pages/psearch.aspx?type=2.4.1&product=2.4.1.3.37&contentType=KB+Article&ostype=&keywords=&items=20>
2- go to drivers and downloads tab.
3- find the appropriate driver according to your operating system. download the driver. In my case i had ATI Radeon 4650 which is in the 4000 series, i downloaded this AMD Catalyst driver <http://support.amd.com/us/gpudownload/linux/legacy/Pages/legacy-radeon_linux.aspx>
4- install the driver
5- play lol

for the people that are using 5000 series or higher, i believe the driver is this one <http://support.amd.com/us/gpudownload/windows/Pages/radeonaiw_vista64.aspx?type=2.4.1&product=2.4.1.3.42;2.4.1.3.44&lang=us&rev=&ostype=Windows%207%20-%2064-Bit%20Edition>

hope this can help you resolve the problem
honor me if it works xP
good luck


Comment below rating threshold, click here to show it.

Dannamoth

QA Analyst

Follow Dannamoth on Twitter

12-04-2012

Quote:
CFlyHigh:
alright guys i have found a way to fix the problem.
what i did was install a driver update from AMD called AMD Catalyst and it somehow updated my graphic card and now i dont have the glitch anymore.

what you need to do to fix this :
1- you need to go on the AMD site
<http://support.amd.com/us/psearch/Pages/psearch.aspx?type=2.4.1&product=2.4.1.3.37&contentType=KB+Article&ostype=&keywords=&items=20>
2- go to drivers and downloads tab.
3- find the appropriate driver according to your operating system. download the driver. In my case i had ATI Radeon 4650 which is in the 4000 series, i downloaded this AMD Catalyst driver <http://support.amd.com/us/gpudownload/linux/legacy/Pages/legacy-radeon_linux.aspx>
4- install the driver
5- play lol

for the people that are using 5000 series or higher, i believe the driver is this one <http://support.amd.com/us/gpudownload/windows/Pages/radeonaiw_vista64.aspx?type=2.4.1&product=2.4.1.3.42;2.4.1.3.44&lang=us&rev=&ostype=Windows%207%20-%2064-Bit%20Edition>

hope this can help you resolve the problem
honor me if it works xP
good luck



If someone using an ATI 5650, that was previously having problems, would update your drivers to verify if that fixes the issue, I would be grateful!


Comment below rating threshold, click here to show it.

Pyro Jedi

Junior Member

12-04-2012

I'm running an ATI Radeon HD 4570, and I don't think I have a secondary graphics card. I tried updating the drivers and didn't make a difference. I also tried setting everything to "very low" (and shadows to "none&quot and that didn't make a difference either. =/ I've uploaded my DxDiag anyway.

I'm just glad I'm not the only person with this issue.


Comment below rating threshold, click here to show it.

Dannamoth

QA Analyst

Follow Dannamoth on Twitter

12-04-2012

Quote:
Pyro Jedi:
I'm running an ATI Radeon HD 4570, and I don't think I have a secondary graphics card. I tried updating the drivers and didn't make a difference. I also tried setting everything to "very low" (and shadows to "none&quot and that didn't make a difference either. =/ I've uploaded my DxDiag anyway.

I'm just glad I'm not the only person with this issue.


Did you take that Dxdiag snapshot after you updated your drivers or before? That is showing your driver version is from 6/15/2009.