Experiencing Latency

First Riot Post
Comment below rating threshold, click here to show it.

Killerarrow

Junior Member

12-10-2012

Quote:
Originally Posted by MrGraveRisen View Post
No, I'm in canada. got shaw. 100mbps line too. AND I'm a network analyst so I have the access to check my connection. it's Riot, not your ISP.
im from mexico and having this problem 2 and was pretty frustrating how i got fb and the double of cs on top and then got an attepting to reconnect, of 25 sec ,suddenly i was 2 lv under and with 15 cs less...i checked my net if i got d/c and someting but was fine so agree with u buddie riot is messing servers again :c


Comment below rating threshold, click here to show it.

MrGraveRisen

Junior Member

12-10-2012

Bump again for potential response


Comment below rating threshold, click here to show it.

Xelle

Junior Member

12-10-2012

Also experiencing this problem. All other connections work fine, in game league is when game side is spiking.


Comment below rating threshold, click here to show it.

Artiburd

Senior Member

12-10-2012

My GOD, almost 17 pages, a noticeable problem, and STILL no reds?

I'm having this too, obviously. Happens both here in NA and on PBE.


Comment below rating threshold, click here to show it.

Rocket Cat

Member

12-11-2012

Still happening.


Comment below rating threshold, click here to show it.

Artiburd

Senior Member

12-11-2012

I think it's gonna keep happening for a while, especially if riot doesn't do anything about it.


Comment below rating threshold, click here to show it.

cpitty

Junior Member

12-11-2012

Really making me mad... I've been playing with lag for a week.


Comment below rating threshold, click here to show it.

Hauntling

Junior Member

12-11-2012

mine started yesterday.. wtf? mad random pingspikes to like 3k 4k etc not my isp


Comment below rating threshold, click here to show it.

MajorPain9

Senior Member

12-11-2012

Also been having the same issues. Sitting at 15+ mbps and this is issue is still happening.


Comment below rating threshold, click here to show it.

OneWingedAce

Senior Member

12-11-2012

I have the same problem.
I live on the West coast and average ~20 ping, but I still get consistent lag spikes. These spikes have intensified significantly since the season 3 patch. Whereas I used to get said spikes every 5 minutes or so, I now find myself frozen multiple times within a minute.