Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


What's with the weird lag/delay when logging into the client?

Comment below rating threshold, click here to show it.

KittensGotClaws

Senior Member

11-25-2012

Quote:
Toysoldier:
Yes I got it now, I just have never heard it referred to as Game Lobby despite that being its real name. So it is just the middle of that screen you cant see where it shows a few news items, but you can still see all the top buttons and bottom buttons like friends list.

I was thinking you meant the screens you get to after clicking play.

If it is any consolation you aren't missing much. It has an ad for the store of the new champ and it shows some headlines you get when logging in or at the homepage of the website.

Have you tried to repair your game before?

It seems that you are either missing/have damaged game files. Or your client is unable to connect to the server properly to retrieve the information which could be from a firewall issue.

If you are using an antivirus software try disabling it for a few minutes and starting up the client. If that doesn't resolve it try looking in firewall settings to allow everything related to League.

Yeah, I know I'm not missing too much, but I thought that since I saw a Tech Red in here, I might as well see if they know how to fix it.


Comment below rating threshold, click here to show it.

pmd

Senior Member

11-25-2012

Quote:
RiotDamiya:
I'm not able to reproduce this behavior. When, precisely, are you alt tabbing? I've tried when the waiting dialog pops, before it, after it and come up dry all around. I always hear the click and transition into the landing page.

'

seems to be working today.

But essentially id type in my password, hit enter, then immediately alt tab, do stuff online for a few mins then go back to league and realize that id never been logged in


Comment below rating threshold, click here to show it.

Yfrappefort

Senior Member

11-25-2012

I got the lag issue with the game client yesterday. I log in, type password, then nothing happen. After around 30 secs, I closed the client and started over. This time it worked fine.

As for the glitch in the champion select, it happened to me a couple of times when I select a champion too fast right as I come in the champion select screen : "This champion is already taken". Even with that, the champion is still selected, but it's annoying and make you wonder if someone picked it even faster then you.

Edit : The login lag issure just happened again today. Had to close the client again, and the second time it worked.


Comment below rating threshold, click here to show it.

Dreampod

Senior Member

11-25-2012

Quote:
RiotDamiya:

This is definitely a behavior I'd like to see quashed, but it's super inconsistent and very hard to reproduce (and accordingly, hard to solve).


I get this super consistently (I think every game but it might have not happened once or twice) along with the 'the server is busy' on my first login attempt (once per login, every login). What can I do to help you squash these bugs? I'll make sure and submit my logs after my next game and tag them for you but if you need anything further just hit me up at my associated email address.


Comment below rating threshold, click here to show it.

Ravechaosknight

Senior Member

11-25-2012

Does this every time I log in now. >.> I have to log in twice to get into the landing page. Also been sitting at this screen the whole time I've been messing around with the screen grab, lol. To be clear what happens is the "Waiting" box pops up for oh 1-2 seconds then it disappears and the log in is nulled out, but all the links and stuff on the page still work.

Not sure about anyone else but this hiccup may be caused by having 2 or more client server files saved to your comp maybe. There is already a well known bug when going between the PBE client and the Live client(You have to run either as an Admin after your first log in or the other won't ). I think this may be similarly linked. I have a Live NA account(well 2), an EUW account, and a PBE account. I don't think my craptop appreciates accessing 3 different sever files. Especially if I jump between them quickly.

Just my 2 cents.


Comment below rating threshold, click here to show it.

TheKMAP

Senior Member

11-25-2012

Quote:
RiotDamiya:
You should be able to get in after a short delay.

One issue that cropped up with the transition to the new Alerter popups (the Yes/No, Waiting, etc dialogs) is that we lost a little bit of feedback on what the Login process is doing, so that leads to some erroneous concerns that nothing's happening. This is a known issue that will hopefully be addressed in the near future.

To the topic at hand: the login process should take 5-15 seconds from the time you hit enter to the time you hit the landing page; that's just a pair of ballpark numbers on my end but it should cover most use cases. I just relogged to ensure that servers are fine and didn't hit any problems.

What sort of behavior are you seeing and how long does it take to get in?

the thing that annoys me is if i type my password too fast i get an error message about the servers being down

gotta wait like 5 seconds before typing my password