Weird launcher problems

First Riot Post
Comment below rating threshold, click here to show it.

Xyshen

Junior Member

11-23-2009

Hi

So far it seems that this problem I am experiencing has not been documented on the forums:

When running the launcher, the eula does not allow me to select "accept" it remains greyed out. I have scrolled to the bottom of the agreement, restarted and tried again to no avail.

I then tried running the other client .exe's I could find: LOL exe just presents the small logo and then does nothing and the lolclient exe gives me a maestro error...

I have also tried reinstalling the client to resolve the issue, but the issue persists.

As I live in South Africa this is quite costly if I have to keep downloading clients as the 500mb I downloaded for the client in effect cost me $4. Thus I would prefer a solution using the existing files I dled or an added patch etc - not a trial and error of downloading the same client multiple times...

Here are the attached screenshots along with a dxdiag and the logs...


Comment below rating threshold, click here to show it.

Habibi

This user has referred a friend to League of Legends, click for more information

Member

11-23-2009

Try running a proxy and see if it works, i had the same issue.


Comment below rating threshold, click here to show it.

Jesse Perring

NOC Technician

11-23-2009
1 of 1 Riot Posts

So, just to clarify, the game MUST be run through lol.launcher.exe. The launcher runs an essential process called maestro that you can't run without.

I believe the problem may be a conflict our game has with Windows 7 64 bit. Try running the game in XP SP2 compatibility. Also, make sure the game is installed outside of the Program Files folder in Windows 7.


Comment below rating threshold, click here to show it.

Xyshen

Junior Member

11-23-2009

Just to clarify, Yes I do know I need to use the launcher, but I was testing whether there are other ways in and gathering as many errors as possible for you guys. Furthermore I don't install any games on my c drive as i keep it primarily for windows...

I have tried the compatibility mode for all the win xp's and lower and none allow me to accept the eula and for ****s 'n giggles I even put on compatibility mode for all the exe's in the game folder...

And before you ask, yes I am admin of my system, yes I have the latest drivers for all my hardware, yes i have tried troubleshooting without the firewalls and anti virus on my pc...

I hope this info in some way help you guys to iron out some bugs for us win 7 people...

EDIT:
Also to test your theory, I have installed the client on a Win Xp pc and had the same problem. Therefore I have to believe that your latest client version is FUBAR...


-Xi


Comment below rating threshold, click here to show it.

reapermaster

Senior Member

11-23-2009

In what method are you using Windows? This particular issue has only previously been seen by users that run windows in parallels or othe Mac OS virtualization software, and Wine.


Comment below rating threshold, click here to show it.

Xyshen

Junior Member

11-23-2009

I do not dual boot or use any form of windows emulation software. Single OS on each pc...




-Xi


Comment below rating threshold, click here to show it.

Xyshen

Junior Member

11-24-2009

I downloaded the client zip (not the setup.exe) and it seems to work fine... Thus reaffirming my theory as to the latest client setup being fubar...



-Xi