Negative Percents Loading--In-game FPS/Lag

Comment below rating threshold, click here to show it.

NewEdge

Member

10-26-2012

So I just built my new PC and it runs every other game fine except this one.

Radeon HD 7770
AMD FX-8150
MSI 760GM-E51FX
8GB Corsair Vengeance DDR3 1333MHz

I have done lots of good searching and there are about 10 threads and not one has a solution. What are you hiding Riot?

Like I said I get negative percentages for players on loading screen. After I load in, the game is unplayable. My character moves across the map in 3 seconds but teleports back to the correct position. Framerate never goes above 25FPS which is impossible for my hardware. I have tweaked every in-game setting, checked any firewall, tried disabling cpu cores, repaired and restarted computer multiple times, checked AMD Control Center to see if graphics card settings were interfering, made sure gpu drivers and all drivers were up-to-date. Sounds like i'm **** out of luck?

This is getting a little out of hand Riot.

http://na.leagueoflegends.com/board/....php?t=1467772
http://na.leagueoflegends.com/board/...d.php?t=212911
http://na.leagueoflegends.com/board/....php?t=2657054
http://na.leagueoflegends.com/board/...d.php?t=167577
http://na.leagueoflegends.com/board/...d.php?t=946998
http://na.leagueoflegends.com/board/....php?t=2082691
http://na.leagueoflegends.com/board/....php?t=1034157
http://na.leagueoflegends.com/board/...d.php?t=776928
http://na.leagueoflegends.com/board/....php?t=2599021
http://na.leagueoflegends.com/board/....php?t=2366389
http://na.leagueoflegends.com/board/....php?t=2616108
http://na.leagueoflegends.com/board/...d.php?t=733184


Comment below rating threshold, click here to show it.

PickleJuice88

Member

10-26-2012

close to same setup here. they just did a patch for it right now


Comment below rating threshold, click here to show it.

NewEdge

Member

10-26-2012

Yeah I got the patch. Its addressing a different issue users are having.


Comment below rating threshold, click here to show it.

NewEdge

Member

10-28-2012

Bump