Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


Low FPS after patch

Comment below rating threshold, click here to show it.

Author Greg

Member

09-17-2010

Lowering the priority does nothing for me.

CPU usage capped at 99% when the launcher/client are running. When they're not, my framerate returns to normal. But I'm sick of closing LolClient.exe every time I want to play the game, because that's stupidly counterintuitive. All of my drivers are up to date, so that's definitely not the problem. I have no trouble running any other games--other games which use WAY MORE processing/graphics power. This is definitely a problem with the AIR client, which is bloated, awful ****.

I almost feel like this started when you guys upgraded to AIR 2.0.

Logs were submitted in-game through the help ticket menu, but if you'd like me to post them here too, I will. I'm wondering if you guys are doing anything about this, considering we keep seeing "post your logs" and "is this actually happening? I've never seen it" as responses, I'm inclined to think maybe you guys aren't actually addressing the FPS issues.


Comment below rating threshold, click here to show it.

Mr Alex

Junior Member

11-22-2010

The low priority trick and close the suff one doesn't work for me :'(

Please help us Riot.

i am on Vista with good computer spec and all is up to date.


Comment below rating threshold, click here to show it.

milobanski

Member

02-05-2011

exactly the same problem


Comment below rating threshold, click here to show it.

Deceus

Junior Member

02-05-2011

I'm not lagging by any means, but I also noticed a large drop of FPS on my computer. Normally I get 200+ FPS , lately it has been shifting from 60 to 90 FPS.

Windows 7 Home Premium 64-bit
Processor: Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz (8 CPUs), ~2.7GHz
Memory: 6144MB RAM
Video Card: NVIDIA GeForce GTX 295 - 1792 MB GDDR3 ( 896MB per GPU )


Comment below rating threshold, click here to show it.

Apoptosine

Senior Member

02-06-2011

I've experienced les FPS also, after the last patch.


Comment below rating threshold, click here to show it.

Weajiin

Senior Member

02-06-2011

Lately I have been having the same frame lag as described by other people in the forum. I played a match against bots to see
if that would change anything and it didnt. So I decided to take down some notes. Unfortunately I had to leave for dinner mid match so the
data is incomplete but atleast it will give you more of a glimpse to the problem than me just saying fix it. I had a hunch my hard disk was
thrashing but after testing that out, I have concluded it is something else. Others have described a drop in framerate of about 30 frames. I
am seeing frame drops in the 25-35 range as well. I also thought that it was only during larger fights. This turns out to not always be the case
aswell. Anyway here are the times at which I had problems.

5v5 Match (Original Summoners Rift)
Me and 4 Bots
vs
5 Bots

My average stats without the lag are

FPS: 44
Latency: 76ms
BattleFPS: 34

The latency stayed constant with +- 20ms even during the lag.

8:10
Lag starts during a 2v1
Me and Sivir Bot vs Annie Bot Mid Enemy Turret
Lag stops after a few seconds
I looked at my harddrive display light and it was off
So no thrashing during this lag.

12:45 Lag brings me to 7fps
Me and Ally Soraka Bot are attacking outermost enemy turret at top
the lag lasts for about 10 seconds.

16:47-17:03 2v2 Chasing enemy bots
no thrashing noticeable.

19:06-19:21
Me and Soraka bot at 2nd top turret

21:20-21:36
7fps from about 38fps
no connection lag just client

24:15-24:31
7fps
78ms

27:37-27:54
**Randomly lags on my way to top from bottom.
Lag in jungle near baron.

30:03-30:19
more lag

32:48-33:05
2v3 at second bottom turret.
had to stop playing because dinner.

Maybe this will help, or maybe I have wasted my time; either way, good luck Riot and hopefully this will be a bug of the past

<System>
Windows 7 64-bit
AMD Turion x2 Dual-Core Mobile RM-72 ~2.1GHz
4096MB RAM
ATI Radeon HD 3200 (1916 MB)
</System>

<Game Config>
[General]
SystemMouseSpeed=0
GameMouseSpeed=10
Width=1024
Height=768
Colors=32
WaitForVerticalSync=0
PredictMovement=0
Windowed=0
UserSetResolution=1
EnableAudio=1
EnableLightFx=0

[Performance]
AutoPerformanceSettings=0
CharacterQuality=0
EnvironmentQuality=0
Full3DModeEnabled=0
GammaEnabled=0
EffectsQuality=0
ShadowQuality=0
FrameCapType=1
ShadowsEnabled=1
EnableParticleOptimizations=0
AdvancedShader=0
AdvancedReflection=1
PerPixelPointLighting=1
PerformanceTestScore=18.5280
</Game Config>


Comment below rating threshold, click here to show it.

milobanski

Member

02-06-2011

Quote:
Maels:
killing lolclient.exe fixed it for me. Still it's a pain having to restart LoL after every game


plus you can't report leavers/afkers/******bags... very annoying


Comment below rating threshold, click here to show it.

furi0us angel

Junior Member

03-17-2011

Lag is killing me.I cannot play a single game without a lag.
Even when i create own game and play with computer it still lag. I reinstalled LOL but lag is still there.
all these weird lag is happening just after the new patch version 1.31.27.Before this patch everything was fine.


PLEASE DO SOMETHING ABOUT THIS CRAZY LAGGGGGGGGGGG.................


Comment below rating threshold, click here to show it.

WhatThePhok

Junior Member

09-18-2011

Setting lolclient to low priority works for me but it ensures my game crashes once randomly every time. Closing the lolclient gets rid of the lag and I don't crash mid-match.


Comment below rating threshold, click here to show it.

Otaku

Senior Member

09-18-2011

I'm having same things. This patch has added about 30seconds or more to loading time. My FPS normally hangs around 20 FPS, but now its so erratic from 10-19 FPS all game, constantly jumping.