Significant FPS Drop after the 6/29/2012 Patch

Comment below rating threshold, click here to show it.

Æther Adept

Member

06-30-2012

i too have been experiencing a heavy drop in fps, experiencing frameskips. also why does it require 4 processes to run LoL now? i remember when it was just 2, then it was 3, now its 4, .........come on, pack it all into 1 process


Comment below rating threshold, click here to show it.

Tempest1230

Junior Member

06-30-2012

Quote:
Originally Posted by ther Adept View Post
i too have been experiencing a heavy drop in fps, experiencing frameskips. also why does it require 4 processes to run LoL now? i remember when it was just 2, then it was 3, now its 4, .........come on, pack it all into 1 process
This I really don't know. Why is it necessary to run it in 4 processes? Lol but eh, it's not like I mind if it's lowered but I want it to be at least 60FPS. It still bugs me that it's gone down from like what? Roughly 350 - 450 on average to like 40 which is alarming to say the least. There should be a reason for this... :/


Comment below rating threshold, click here to show it.

Gumurak

Senior Member

06-30-2012

The different processes are in preperation for league to come up with a system that spreads the resources across several cores. Which currently would set a new precident in gaming. Weather theya ccomplish it or not is an entirely different subject.


Comment below rating threshold, click here to show it.

Elysius

Senior Member

07-01-2012

The game should run in a dual core at 60 fps all the time.. I don't know if this are memory leaks or something similar but for some reason the framerate drops for a few seconds at random points.. I have a quead at 2.8 and the framerate drops anyway with shadows off

I hope they fix it soon


Comment below rating threshold, click here to show it.

mystical wizard

This user has referred a friend to League of Legends, click for more information

Member

07-01-2012

I'm getting this FPS drop. I was running around 70-90 and now it drops to 7-9 in team fights. It's terrible.


Comment below rating threshold, click here to show it.

Timmage

Junior Member

07-01-2012

exact same problem. will make millions of skin but bugged game so prob no fix lol =P


Comment below rating threshold, click here to show it.

PitBullDog

Junior Member

07-01-2012

Same i had fps drop after the patch


Comment below rating threshold, click here to show it.

Gumurak

Senior Member

07-01-2012

Quote:
Originally Posted by Timmage View Post
exact same problem. will make millions of skin but bugged game so prob no fix lol =P
It's not really bugged, 90% of the time it's something to do with your own system. Because across 8 different computers in this house. Not a single one has this or any other problem, except one that had missing runes.


Comment below rating threshold, click here to show it.

iimthomas

Senior Member

07-01-2012

yeah mine started last night, i would get over 60+ fps on max settings no problem, not its around 30 and it lags... what the heck.


Comment below rating threshold, click here to show it.

dRein

Junior Member

07-01-2012

As I'm having the same problem, I did some testing.

I went jungle mundo for all of my testing, in a custom game with bots.

For the first 5 minutes, my fps was a constant 60 whether i was ganking, farming jungle, or farming lane minions.

I noticed previously having no lag problems early game, but after a certain time, i would lag constantly. This happened for at least 5 games. I paid close attention when i was doing the last 2 games of my testing, and i experienced a significant change at 5:50ish for one game, and 6:50ish for another game. Now remember, until this point, "whether ganking, farming jungle, or farming lane minions", i had constant 60 fps.

Suddenly for both games,after reaching those specificish times(5:50 and 6:50), if i was ganking or farming lane minions or farming jungle minions, my fps dropped to 10-20.

If while i was ganking or farming, I focused my screen far off in an uneventful area, I would be at 60 fps. If i watched a "busy" area, whether my character was involved or not, I would be at 10-20 fps.

Does this indicate severe memory leakage as others have previously mentioned?