Welcome to the Forum Archive!

Years of conversation fill a ton of digital pages, and we've kept all of it accessible to browse or copy over. Whether you're looking for reveal articles for older champions, or the first time that Rammus rolled into an "OK" thread, or anything in between, you can find it here. When you're finished, check out the boards to join in the latest League of Legends discussions.

GO TO BOARDS


[Tool] Spectate Anyone!

Comment below rating threshold, click here to show it.

skarlight

Member

06-18-2012

Quote:
Jabe:
Did you try running the batch as Administrator (right-click)? Also, your region needs to be EUW, not EUWest.



Download the new version. You can blame Windows notepad for this since it saves an extra 3 bytes at the beginning of the file when you save as UTF8 (make sure you save as UTF8 and not a different encoding).


I downloaded the new tool version, although i don't know how to save the file as UTF8, and the problem still occurs.
in the config.txt file the first line is like this:
lollocation=D:\J*t‚kok\Riot Games\League of Legends\
as you can see the "á" and "é" are left out

Edit: I made sure i saved the config.txt in UTF8 format, and it still doesnt work for me :S


Comment below rating threshold, click here to show it.

FrozenBite

Junior Member

06-18-2012

Quote:
Jabe:
If you don't want to tinker with the settings in the registry, the other thing you could do is learn how to use the command prompt and cd to the directory with the jar file, then type "java -jar SpectateAnyone.jar". That's what double clicking on the batch file should do automatically, but isn't in your case.

I fully trust you, what I meant is that i didn't know what to do after deleting the "b- notepad++" and didn't want to make a mistake. As long as you tell me what I should do I have no problem with it!
I'm going to try for the command prompt, and I'll tell you if I can get it to work!
thank you as always

EDIT : if the files are on my desktop, should I use START "" C:\Users\Me\Desktop\SpectateAnyone.jar "java -jar SpectateAnyone.jar" ?
I hope not because it doesn't do anything


Comment below rating threshold, click here to show it.

Jabe

Member

06-18-2012

Quote:
skarlight:
I downloaded the new tool version, although i don't know how to save the file as UTF8, and the problem still occurs.
in the config.txt file the first line is like this:
lollocation=D:\J*t‚kok\Riot Games\League of Legends\
as you can see the "á" and "é" are left out

Edit: I made sure i saved the config.txt in UTF8 format, and it still doesnt work for me :S


When you saved as UTF8 did the characters appear in the file correctly? They should be showing up correctly in the file like so - http://i.imgur.com/DQWCC.png

Quote:
FrozenBite:
I fully trust you, what I meant is that i didn't know what to do after deleting the "b- notepad++" and didn't want to make a mistake. As long as you tell me what I should do I have no problem with it!
I'm going to try for the command prompt, and I'll tell you if I can get it to work!
thank you as always

EDIT : if the files are on my desktop, should I use START "" C:\Users\Me\Desktop\SpectateAnyone.jar "java -jar SpectateAnyone.jar" ?
I hope not because it doesn't do anything


After starting a command prompt, you can do the following to run it:
cd C:\Users\Me\Desktop\ (change to the directory that the file is in)
java -jar SpectateAnyone.jar (run the program


Comment below rating threshold, click here to show it.

skarlight

Member

06-18-2012

Quote:
Jabe:
When you saved as UTF8 did the characters appear in the file correctly? They should be showing up correctly in the file like so - http://i.imgur.com/DQWCC.png


Yes, when i saved the file as UTF8 then reopened it, those characters remained, although whenever i try to config the .bat, it says the lollocation doesn't appear to be valid, and i have been getting this error message ever since the first try.
In some other cases after sone try the letters suddenly disappear.
If there is no solution for this, does this mean that i have to reinstall LoL into some other directory, which has no such letters?


Comment below rating threshold, click here to show it.

Jabe

Member

06-18-2012

Quote:
skarlight:
Yes, when i saved the file as UTF8 then reopened it, those characters remained, although whenever i try to config the .bat, it says the lollocation doesn't appear to be valid, and i have been getting this error message ever since the first try.
In some other cases after sone try the letters suddenly disappear.
If there is no solution for this, does this mean that i have to reinstall LoL into some other directory, which has no such letters?


You have a few options: (#1 & #2 will mess up any shortcuts you have to the game)
1) Rename the directory that has the special characters in it
2) Cut and Paste the Riot Games folder to a directory that doesn't have the special characters in it
3) Reinstall LoL
4) More attempts for fixing config.txt, since Notepad might be doing something strange. Open config.txt, copy all of the text. Close it. Delete config.txt. Create a new text file called config.txt. Paste the text. Save it as UTF8.


Comment below rating threshold, click here to show it.

Traoborn

Junior Member

06-19-2012

I try it and it says that is not recognizable


Comment below rating threshold, click here to show it.

Jabe

Member

06-19-2012

Quote:
Traoborn:
I try it and it says that is not recognizable


Quote:
Original post:
-- If you get the error "'java' is not recognized as an internal or external command..." 1) make sure you have Java installed 2) you need to add Java to the PATH -- see here (http://java.com/en/download/help/path.xml) and here (http://na.leagueoflegends.com/board/showthread.php?p=25142262#post25142262) 3) check your PATHEXT variable and make sure it has .EXE in it.


Quoted from orignal post.


Comment below rating threshold, click here to show it.

Frostbutt Irelia

Senior Member

06-19-2012

this is amazing


Comment below rating threshold, click here to show it.

skarlight

Member

06-20-2012

I reinstalled LoL into other directory which doesn't contain "special" letters, and it's working now. Thanks!


Comment below rating threshold, click here to show it.

Traoborn

Junior Member

06-20-2012

Thanks, it works now