Crippling Adobe AIR Crashes

Comment below rating threshold, click here to show it.

Zombie Buffalo

Member

06-08-2012

Hello Riot! I started playing the game a month back after a long break, but I have noticed a horrible problem. The launcher will just crash randomly, saying "Adobe Air Debug Launcher Has Crashed". It happens mainly during champion select, and it has caused me to lose loads of ELO rating. Additionally, my connection to PvP.net isn't that stable - I am constantly connected and disconnected, maybe this has something to do with it.

Anyways, I have tried:
-Completely reinstalling the game (I followed your guide)
-Running as administrator
-Uninstalling Skype
-Disabled my firewalls

Any help would be greatly appreciated, because I find I can't even get through Champion Selection anymore.

I attached some data you guys may find useful...

Here is a link to my Netalyzr

Netalyzr


Comment below rating threshold, click here to show it.

Zombie Buffalo

Member

06-08-2012

bump


Comment below rating threshold, click here to show it.

Zombie Buffalo

Member

06-08-2012

bump


Comment below rating threshold, click here to show it.

Zombie Buffalo

Member

06-08-2012

bump


Comment below rating threshold, click here to show it.

Zombie Buffalo

Member

06-08-2012

bump


Comment below rating threshold, click here to show it.

ImMystiik

This user has referred a friend to League of Legends, click for more information

Member

06-08-2012

wats bump?


Comment below rating threshold, click here to show it.

Zombie Buffalo

Member

06-08-2012

bump


Comment below rating threshold, click here to show it.

Zombie Buffalo

Member

06-09-2012

bump


Comment below rating threshold, click here to show it.

Zombie Buffalo

Member

06-09-2012

bump


Comment below rating threshold, click here to show it.

Karlor

Junior Member

06-09-2012

Are you using a router? sounds like communication error with the LoL servers, you mentioned disabling the firewall, did you open the ports on your router?
https://support.leagueoflegends.com/...ort-forwarding
Make sure you have EVERYTHING updated, you should have the most recent updated windows/adobe/graphic card updates