League of Legends WORKING on Linux

First Riot Post
Comment below rating threshold, click here to show it.

futmeK1VYvImO7RT

Senior Member

12-05-2012

that sucks.. my game crash too when i open the shop.


Comment below rating threshold, click here to show it.

futmeK1VYvImO7RT

Senior Member

12-05-2012

how i download and install that patch? the link open me a web browser page


Comment below rating threshold, click here to show it.

Xatulu

Junior Member

12-05-2012

Well, you all need to recompile Wine until POL offers a new wine version..
If you already have all the dependencies for Wine1.5, you could try the build i compiled (http://dl.dropbox.com/u/19900472/1.5...pdated2.tar.gz). It was compiled using Linux Mint 14 (Ubuntu 12.10), but if you have all the required dependencies, it should work.

If you want to use it in POL, extract it in your /home/$USER/.PlayOnLinux/wine/linux-x86/ directory (via tar or press Ctrl + H in personal folder to show the hidden folders), press configure in POL on LoL and switch the used Wine version to 1.5.18-LoL-updated2.

Or extract it whereever you like, change into the bin directory of the extracted folder and use the wine-binary in it to launch LoL.

It works fine for me (with some store issues (red boxes instead of item symbols)), but apart from that everything but buying runes/rp works.


Comment below rating threshold, click here to show it.

laochuangtzu

Junior Member

12-05-2012

I've gotten the launcher to start, but it won't go past the "Calculating Differences" step at the beginning. I'm certain the folder I have is up to date, though I'm not sure if that's relevant. Any ideas?


Comment below rating threshold, click here to show it.

Xatulu

Junior Member

12-05-2012

Quote:
Originally Posted by laochuangtzu View Post
I've gotten the launcher to start, but it won't go past the "Calculating Differences" step at the beginning. I'm certain the folder I have is up to date, though I'm not sure if that's relevant. Any ideas?
Try restarting lol. If the problem persists, delete /LOL/RADS/projects/lol_air_client and start it again, then it will perform a full update and should be working.


Comment below rating threshold, click here to show it.

laochuangtzu

Junior Member

12-05-2012

Quote:
Originally Posted by Xatulu View Post
Try restarting lol. If the problem persists, delete /LOL/RADS/projects/lol_air_client and start it again, then it will perform a full update and should be working.

Worked like a charm! Thank you, my man.


Comment below rating threshold, click here to show it.

laochuangtzu

Junior Member

12-05-2012

Alright, new issue. When I start a game, I have a black screen after champ choosing. Also, my whole display is now a square on my widescreen monitor. I could hear the game sounds and could cast spells and walk and whatnot, just couldnt see anything in the game window. I could, however, see the terminal working the entire time, even after five or so minutes in game and after the window closed automatically.


Comment below rating threshold, click here to show it.

futmeK1VYvImO7RT

Senior Member

12-07-2012

EDIT
SOLVED

If someone still need to fix the problem, follow this little guide:

1. Install PlayOnLinux 4.1.x,
2. Install button > Check "In testing" checkbox > Games > League of Legends
4. Download http://dl.dropbox.com/u/19900472/1.5...pdated2.tar.gz
5. untar it
6. Place the untared folder under /home/$USER/.PlayOnLinux/wine/linux-x86/
7. Open PlayOnLinux
8. Configure your LoL-Installation
9. Switch the used wine version from 1.5.5-LeagueofLegends to 1.5.18-LoL-updated2
10. Enjoy.


Comment below rating threshold, click here to show it.

tantal

Junior Member

12-08-2012

Quote:
Originally Posted by Xatulu View Post
Well, you all need to recompile Wine until POL offers a new wine version..
If you already have all the dependencies for Wine1.5, you could try the build i compiled (http://dl.dropbox.com/u/19900472/1.5...pdated2.tar.gz). It was compiled using Linux Mint 14 (Ubuntu 12.10), but if you have all the required dependencies, it should work.

If you want to use it in POL, extract it in your /home/$USER/.PlayOnLinux/wine/linux-x86/ directory (via tar or press Ctrl + H in personal folder to show the hidden folders), press configure in POL on LoL and switch the used Wine version to 1.5.18-LoL-updated2.

Or extract it whereever you like, change into the bin directory of the extracted folder and use the wine-binary in it to launch LoL.

It works fine for me (with some store issues (red boxes instead of item symbols)), but apart from that everything but buying runes/rp works.
I also have problems with the new parch. When the game starts, screen freezes after 2 sec and i can't eaven move to another workspace. I tried to dl your update2.tar file untar it and place it in the correct folder, but when i start lol, POL pops up with an eror.


Comment below rating threshold, click here to show it.

Dromiceioemimus

Junior Member

12-09-2012

Has anyone tested this package? I just managed to get my Optimus Nvidia working, and the game seems to run flawlessly