MAJOR Janna bugs - Unable to plant pink wards or shield turrets + Frame Rate Drop

Comment below rating threshold, click here to show it.

YurdleTheTurtle

Senior Member

02-17-2012

Unfortunately I could not get screenshots off as I was pressing the print screen button, and then found out apparently the screenshot button is F12. And even then, I can't find the screenshot folder.

Anyways...

Bug:
1. At some point in the game, as Janna, I was randomly and permanently (for the rest of the game) unable to plant pink Vision Wards at all.

When attempting to plant it, it would say "Invalid, please select a valid target" (or something similar), as if it was a single target spell. If I selected a target (like myself or another unit), nothing would happen.

In addition, when selecting the pink ward to use, the AoE range indicator was smaller than the actual planting range.

My guess is the pink ward somehow got mixed up with another spell and all of a sudden tried using it's targeting algorithm to do something it could not do.
This only prevented me from planting pink wards. Green wards were still working fine.

2. At some point in the game, as Janna, I was randomly and permanently unable to target or select the base towers next to our Nexus. I could not see their health, nor target them with spells.

3. Late in the game, the frame rate suddenly decreased and stayed at an average of 10-15. It would dip even lower when team fights occured. Interestingly enough, this has never happened before. It only started happening after Nautilus patch and ONLY when I play as Janna.

Note that the above has only occurred when I was playing as Janna. The frame rate bug has occurred twice, while the ward and 'unable to target turrets' bug has only occurred once.


Comment below rating threshold, click here to show it.

YurdleTheTurtle

Senior Member

04-12-2012

Update: Encountered the ward bug again.

I haven't had any frame rate drops in a long time so it may have been an old patch problem - same goes with turret bug. However, I did encounter not being able to plant wards again while playing as Janna. The pattern seems random - I have no idea how to reproduce it, just been playing as Janna hoping to never encounter it.

Again, I was unable to plant Vision (pink) wards at all. Green wards still worked, but pink wards could not be planted. It gave the same error, asking to choose a "valid target", and when you did try to target a unit/structure, nothing would happen.

I managed to fix the bug in-game by reconnecting, although it's a pretty major bug that needs a real solution. It's a big deal right now and I can only imagine what would happen if it occurred in a tournament match.