the new way to run LoL in ubuntu (working!)

Comment below rating threshold, click here to show it.

Wesker Bot

Member

02-29-2012

Quote:
Originally Posted by urmamasllama View Post
you'll have to look up how to make a shell script to automate the startup

as for your other issue the only thing i can tell you to try is installing vcrun2008 one of the installs i did had a problem with 2005 and installing 2008 seemed to fix it

also install the d3dx9_XX dll's
i have tried everything playonlinux -> league of legends patch
wine 1.2
wine 1.3
tons of stuff on crossover games or standard (i had hope xP)
the best result i ever got, was been able to click play now and then it crashed

i have tried every solution available
net 1.1
direct x 9
vcrun2005-08
ie 6.1

you name it, i tried everything i have even remove/install wine like 30 times by now, now my only question right now will be are you able to play it on linux ?
following this guide ?
or
http://na.leagueoflegends.com/board/...d.php?t=973373
or the ace client

i seriusly got no idea what to try now <_<
seems im not the only 1 : http://www.playonlinux.com/en/topic-4372.html

this http://www.playonlinux.com/repository/?script=781
didnt work eigther

also tried this small guide avobe : http://appdb.winehq.org/objectManage...sion&iId=19141

didnt help at all, not even the install pop-up, ubuntu 32 bits

i tried wine on xp, win7, all the rest of the o.s (just because hope should never die, but it is diying....)

if any1 right now can tell me how they manage to work it, ill appreciate it alot, maybe some step i didnt do, that you found some where else idk, i tried everything, the ace client isnt a real solution the shop didnt work, even wen i installed the wint thing they recomended or whatever its called

thanks again


Comment below rating threshold, click here to show it.

urmamasllama

Senior Member

02-29-2012

in my guide i say you HAVE TO have 1.4 which i linked to in the guide how to do it

the older guide with the ace client requires more than is listed in his guide and i personally could never get it to work

so i assume his guide doesn't work anymore


Comment below rating threshold, click here to show it.

r1rUrJJ

Junior Member

03-04-2012

thanks for the guide.
I got everything running good, except it couldn't login to the game, it said connection error and unable to connect to pvp.net. Any ideas about that?


Comment below rating threshold, click here to show it.

urmamasllama

Senior Member

03-05-2012

Quote:
Originally Posted by r1rUrJJ View Post
thanks for the guide.
I got everything running good, except it couldn't login to the game, it said connection error and unable to connect to pvp.net. Any ideas about that?
did you install inet with winetricks?

its probably either that or your firewall


Comment below rating threshold, click here to show it.

urmamasllama

Senior Member

03-05-2012

just updated to 1.4 rc6 still has some bugs with the patcher getting stuck at 0% and 33% but a after a few tries it works fine


Comment below rating threshold, click here to show it.

r1rUrJJ

Junior Member

03-06-2012

Quote:
Originally Posted by urmamasllama View Post
did you install inet with winetricks?

its probably either that or your firewall
After upgraded to wine 1.4rc6, it is working perfectly, except the in-game store.


Comment below rating threshold, click here to show it.

urmamasllama

Senior Member

03-08-2012

1.4 final release is out meaning you don't even have to add the software source anymore

this is fantastic news seeing as that cuts the work needed in half


Comment below rating threshold, click here to show it.

Raboebie

Junior Member

03-09-2012

Quote:
Originally Posted by Wesker Bot View Post
i have tried everything playonlinux -> league of legends patch
wine 1.2
wine 1.3
tons of stuff on crossover games or standard (i had hope xP)
the best result i ever got, was been able to click play now and then it crashed

i have tried every solution available
net 1.1
direct x 9
vcrun2005-08
ie 6.1

you name it, i tried everything i have even remove/install wine like 30 times by now, now my only question right now will be are you able to play it on linux ?
following this guide ?
or
http://na.leagueoflegends.com/board/...d.php?t=973373
or the ace client

i seriusly got no idea what to try now <_<
seems im not the only 1 : http://www.playonlinux.com/en/topic-4372.html

this http://www.playonlinux.com/repository/?script=781
didnt work eigther

also tried this small guide avobe : http://appdb.winehq.org/objectManage...sion&iId=19141

didnt help at all, not even the install pop-up, ubuntu 32 bits

i tried wine on xp, win7, all the rest of the o.s (just because hope should never die, but it is diying....)

if any1 right now can tell me how they manage to work it, ill appreciate it alot, maybe some step i didnt do, that you found some where else idk, i tried everything, the ace client isnt a real solution the shop didnt work, even wen i installed the wint thing they recomended or whatever its called

thanks again
Hi

I think i might have breaking news for you!! If you are using the current nvidia 295.2 drivers then this is why it crashes when u click play. You need to downgrade to 290.1 for lol to run on wine !!

Check this link : http://appdb.winehq.org/objectManage...sion&iId=19141 (You need to scroll down some after the page loads)


Comment below rating threshold, click here to show it.

Raboebie

Junior Member

03-09-2012

Hi

I have got my lol working using this tutorial but now when i entre a game everythings works fine as it should accept for the terrain that is completely black? I have downgraded my drivers to make this work may this be the cause? Are there any ideas?


Comment below rating threshold, click here to show it.

urmamasllama

Senior Member

03-09-2012

ill have to check what version of drivers im running myself