No Announcer Voice ~ Help Please

First Riot Post
Comment below rating threshold, click here to show it.

Eunson

Senior Member

12-15-2011

So I recently purchased a new computer and I installed league. Everything is running smoothly. There is one problem...there is rarely an announcer voice. For about every 5th kill the announcer will announce that something has happened (tower down, enemy dead, etc.) I then reinstalled league thinking there was a problem the first time I installed it. The announcer voice worked fine for the first game. It announced every kill. Ever since that game, the announcer voice has gone back to almost never saying anything. I have looked around the forums and found many links about this problem. There is the constant "bump" for riot to finally pay attention to this problem and so far I have not found a reply on how to fix it. I was just wondering if the community has any solutions or if Riot has posted how to fix this and I have just not come across it. I would appreciate this very much if anyone has a solution to this.

PS - the game just loses a certain when you get a kill or three.


Comment below rating threshold, click here to show it.

Eunson

Senior Member

12-15-2011

I have also already set my sound to "Stero" and not 5.1. I would try the repair game option but I figured reinstalling would also fix the issues unless I got unlucky twice? o.O


Comment below rating threshold, click here to show it.

Eunson

Senior Member

12-17-2011

Just tried to LoL repair button. Still nothing.


Comment below rating threshold, click here to show it.

Eunson

Senior Member

12-18-2011

The banner doesn't display either when a tower is destroyed.


Comment below rating threshold, click here to show it.

veksen

This user has referred a friend to League of Legends, click for more information

Junior Member

12-18-2011

I have the same issues, with no changes to my software or hardware, I'm missing more than half the summoner sounds. Everything played well before, looked around, no answer from red, we're left in the dark with that issue.

I was thinking it would be corrupted files, but a repair would fix it, it doesn't.


Comment below rating threshold, click here to show it.

Eunson

Senior Member

12-19-2011

I have looked through the forums and this is a constant issue riot ignores. I was hoping someone from the community would know because riot seems more keen on making more champions for $ instead of fixing the problems with their client. I could list over 100 problems easily but this one I can't seem to get around myself :/


Comment below rating threshold, click here to show it.

jaywatford

Lead Sound Designer

12-19-2011
1 of 1 Riot Posts

Hey guys,

To clarify, is it just the voice you are not getting, or is the banner also not displaying? This will help us identify if this a problem with the VO playback, or the announcement system. More info would be a big help, thanks in advance!


Comment below rating threshold, click here to show it.

FerralOne

Senior Member

12-19-2011

The banner also doesn't display (In most cases for me at least. On occasion, the banner shows and the VO doesn't play)

EDIT: Also, I re-installed league of legends about 2-3 weeks ago, along with pretty much everything else on my PC (Virus), It's not the install.


Comment below rating threshold, click here to show it.

Eunson

Senior Member

12-19-2011

It displays about 1/5 times per kill/tower destroyed. It announces about 1/10 kill. Very rarely hear double kill, multi kill, etc.


Comment below rating threshold, click here to show it.

d10p3t

Recruiter

12-19-2011

in my case its the "you inhibitor has respawned" and "the enemy's inhibitor has respawned" but the text at top still appears. i noticed it a few patches ago but always forget to report it.