Info - LoL System Requirements

1234567 ... 9
Comment below rating threshold, click here to show it.

Ron Burgundy

Junior Member

10-28-2009

Quote:
Originally Posted by Malign View Post
Dedicated DOTA player. I have a copy of beta and would be overjoyed to preorder the deluxe edition and contribute financially to the game. However I, like many of my friends, am a Mac user. If Mac support is not made available Riot Games will be losing out on a significant amount of sales. Recent sales data indicates that 94% of portable computers sold in the US last quarter that cost over $1000 were Macs.

This means that the individuals who are most likely to spend money on the non-free features of the game will be unable to play it without installing Boot Camp.

For the majority of PC-humping forumites who probably don't know the first thing about Boot Camp, let alone a Mac beyond personal bias, may I add that the majority of Mac users do not use the program. I personally find it a tremendous joke to be expected to turn my Mac into a PC in order to play LoL, sacrificing a large chunk of memory and exposing my computer to all of the OS bugs and problems I stopped using PC to get away from.

Icefrog, Riot Games, forumites, please get on the bandwagon for Mac/Linux support. It's what Blizzard Entertainment does. It's what most major developers do, and (regardless of what the majority will say), these niche players are income just waiting to be harvested.

tl;dr, but that's my two cents.

-Malign
pretty much all macs cost over a grand, most people who buy macs dont play games (some schools around the US require one, which might take a huge chunk out of your percentage), you dont like windows probably because it has lots of problems.. the more flexible an OS is, of course its going to have lots and lots and lots of problems. (theres a reason why programmers choose PCs instead of macs) so if you want you can say PCs are for gamers and nerds and people who know computers, and macs are for people who like... um, blogging and dont know anything else, maybe facebook.

at least thats how i see it ^^


Comment below rating threshold, click here to show it.

selovanth

Senior Member

11-01-2009

I have the requirements for this game but for some reason I have a problem playing this game.

http://www.leagueoflegends.com/board...ad.php?t=22397


Comment below rating threshold, click here to show it.

thewaterwarrior

Junior Member

11-03-2009

Quote:
Originally Posted by Xocolatl View Post
I am using ASUS Aspire1 with the Intel945 or whatever chipset. It does not support vertex shader 2.0. On mostly low setting, I am running the game at 15FPS. It's not stellar, it is still playablefor gaming on the go (on a budget).

So to all players out there running EEE laptops--yes, you will be able to play LoL. It's nothing to write home about, but considering the only two games that ever run on my laptop is WoW and LoL, it's a huge feat to accomplish.
How were you able to run it at all if you video card doesn't support the vertex shader 2.0?

When I try to launch I get an error and the game shuts down. I'd love to play with some min settings and a bit of lag but can't even do that before I upgrage my graphics card. Thanks.


Comment below rating threshold, click here to show it.

Malign

Junior Member

11-03-2009

Quote:
Originally Posted by Ron Burgundy View Post
pretty much all macs cost over a grand, most people who buy macs dont play games (some schools around the US require one, which might take a huge chunk out of your percentage), you dont like windows probably because it has lots of problems.. the more flexible an OS is, of course its going to have lots and lots and lots of problems. (theres a reason why programmers choose PCs instead of macs) so if you want you can say PCs are for gamers and nerds and people who know computers, and macs are for people who like... um, blogging and dont know anything else, maybe facebook.

at least thats how i see it ^^
Read the forum posts, remembering that this is a game that has been announced as non-Mac-friendly, and notice all the registered posters who have friends or are themselves interested in running the game on a Mac. it is a common, unfounded, and outdated argument to state that Mac users do not game. I have many, many friends who use their macs to play games ranging from WC3 and WoW, to Modern Warfare 2 - and this number grows by the month. For PC users this seems to have become the equivalent of the gay marriage debate - it does not effect them and yet they are the ones more adamantly opposed to providing the service. I suggest that both you and Riot Games do some economic research on the growing Mac gaming community and view this as an opportunity to get the game into a wider audience's hands. If it helps the game become more well-known (which it will), if it would generate more revenue than the research would cost (which it would), then there is no reason not to explore a Mac release.


Comment below rating threshold, click here to show it.

TiLeN

Junior Member

11-07-2009

I'd also be very happy to see a MAC client


Comment below rating threshold, click here to show it.

crazygerbil

Junior Member

12-03-2009

While I am not very interested in a mac client, I would be extremely happy to have a Linux client.


Comment below rating threshold, click here to show it.

Ezra The Fat One

Junior Member

01-28-2010

i have windows xp and 510MB of RAM i want to play LoL but i cant cuz i have 510 and i dont want to buy anything.... is there any other way i can play LoL. Ty.


Comment below rating threshold, click here to show it.

fartsfignewton

Junior Member

06-15-2010

I don't even have SLI enabled but installing the driver that allows me to use SLI causes the game to crash instantly. Any ideas that don't involving turning off SLI?


Comment below rating threshold, click here to show it.

King Ozai

Junior Member

06-30-2010

I have 512 MB graphic card..But still cant play..It says "Your graphic card doesnt support shader model 2.0" something something..Please advice.


Comment below rating threshold, click here to show it.

Aregionius

Senior Wrenchman

06-30-2010

You may need to update your graphics card drivers if your card is new enough to support shader model 2.0


1234567 ... 9