Can't open game...

First Riot Post
Comment below rating threshold, click here to show it.

RoyalCheetah

Junior Member

10-01-2013

Even after trying after many many attempts including SirOwned's fix, still does not open for me
Update us if you find the problem Riot

(Also have 10.6.8 mac)


Comment below rating threshold, click here to show it.

Dannamoth

QA Analyst

Follow Dannamoth on Twitter

10-01-2013
3 of 7 Riot Posts

Quote:
Originally Posted by RoyalCheetah View Post
Even after trying after many many attempts including SirOwned's fix, still does not open for me
Update us if you find the problem Riot

(Also have 10.6.8 mac)
We're definitely working on this full tilt. We're still not 100% sure what's going on. Still doing investigation.


Comment below rating threshold, click here to show it.

Doct0r

Member

10-01-2013

Hey please help us who lost our champions this patch? There's over a portion of us.


Comment below rating threshold, click here to show it.

Dannamoth

QA Analyst

Follow Dannamoth on Twitter

10-01-2013
4 of 7 Riot Posts

Quote:
Originally Posted by Doct0r View Post
Hey please help us who lost our champions this patch? There's over a portion of us.
That's a separate issue than the one in this thread. You should submit a request to player support. They can help iron out issues with missing content.

Link to submit a support ticket: https://support.leagueoflegends.com/home


Comment below rating threshold, click here to show it.

2muchBlame4Days

Junior Member

10-01-2013

Same thing is happening to me here after downloading the latest patch. The method of opening it over and over again seems to work. After opening like 50 times it finally actually launched the game.


Comment below rating threshold, click here to show it.

FL1P7H1S

Recruiter

10-01-2013

Same problem here! Mac OSX 10.6.8 patched like 20 mins ago and seemed to be buggy after login. Was invited to play a game, then when the party leader started up, I was by myself in the lobby. Decided to relaunch client and now can't get past the "Play" button. It just keeps closing every time.


Comment below rating threshold, click here to show it.

iijimae

Junior Member

10-01-2013

Quote:
Originally Posted by SirOwn3d View Post
I HAD the same problem!! and suddenly it seemed to work!


TRY THE FOLLOWING:
-CLICK ON REPAIR

A MESSAGE WILL APPEAR TELLING YOU IT WILL TAKE A ****LOAD OF TIME

-CLICK NO
-CLICK PLAY AGAIN


I've no ****ing idea why this works but that trick does it always now on my macbook!!
gl&hf guys!

UPVOTE IF THIS WORKS FOR YOU
Do this several times and it will work! I hope they fix this problem soon though...


Comment below rating threshold, click here to show it.

Rhozes

Member

10-01-2013

Yup, same issue. Mac OSX 10.6.8, game closes down from launcher and won't take me to the login screen. Tried all the suggested fixes and nothing. I think it's worth mentioning that my Mac had a system update today, but I also don't think that has anything to do with it. I tried and failed to open the client one time before the SU.


Comment below rating threshold, click here to show it.

chuubert

Junior Member

10-01-2013

can't seem to get on either. tried several times now it finally worked? what the heck just happened?


Comment below rating threshold, click here to show it.

Rugby Rocket

Junior Member

10-01-2013

Mac os 10.6.8 Mac Pro HAAALP can't get in!!!!