Mac client unable to launch/start games

First Riot Post
12
Comment below rating threshold, click here to show it.

Riot NOC

Network Operations Center

05-02-2013
1 of 1 Riot Posts

Hello Summoners,
We are experiencing problems with the Mac client unable to login or launch games. We are sorry for the inconvenience and are working to fix this problem.


Comment below rating threshold, click here to show it.

Dataslave

Adjudicator

05-02-2013

This only affects the PBE client, but thanks for the heads up


Comment below rating threshold, click here to show it.

iTzX

Junior Member

05-04-2013

Quote:
Originally Posted by Dataslave View Post
This only affects the PBE client, but thanks for the heads up
I have this is effect on the actual Mac Beta Client not only the PBE.

Thank you for letting us know Riot Noc I hope you guys find a fix soon.


Comment below rating threshold, click here to show it.

Dataslave

Adjudicator

05-04-2013

Quote:
Originally Posted by iTzX View Post
I have this is effect on the actual Mac Beta Client not only the PBE.

Thank you for letting us know Riot Noc I hope you guys find a fix soon.
You're mistaken; The issue he's posting about is PBE only, was affecting every mac user for a short timespan, and has since been fixed.

If you'd like to start a thread about your specific problem, we can help you find a solution.


Comment below rating threshold, click here to show it.

boevice

Junior Member

05-07-2013

My specific problem is I cannot even get to the loggin screen, I will click play and nothing will happy. League application will just close out.


Comment below rating threshold, click here to show it.

Dataslave

Adjudicator

05-07-2013

Quote:
Originally Posted by boevice View Post
My specific problem is I cannot even get to the loggin screen, I will click play and nothing will happy. League application will just close out.
They're still trying to track down this bug. Its sometimes caused by closing the client forcefully, and sometimes through using the Repair function. The issue seems to be that a file that's usually called to launch the game just disappears, and thus nothing happens when you try to open the game.

Reinstalling fixes the issue obviously, but its a lot of data to re-download. You can also reinstall, but copy over your patch files from the old client. You can also attempt to repair the issue with your client manually. The latter two methods are basically doing the same thing, just merging your patch download data with a working copy of the missing file.

If you could, go to this thread and follow the instructions to post a copy of your client on that thread; They need a "broken" install to help them track down this issue. You may want to make a copy of your League of Legends.app file first, and then follow his instructions on that copy; Otherwise you're going to be forced to reinstall the game.

To fix it manually:
1) Open a new Finder window, navigate to your Applications folder, and find League of Legends.app
2) Right click, Show Package Contents
3) Double click on Contents, then LOL, then RADS, then system.
4) Keep this window open for a bit.

5) Re-download the League Of Legends NA.dmg install file.
6) Open the file. A window will appear with a picture of Ryze, a League of Legends.app file, and a shortcut to your Applications folder.
7) Right click on League of Legends.app, Show Package Contents.
8) Double click on Contents, then LOL, then RADS, then system.
9) There's a file in here called UserKernel.app, and you want copy it to the other window you have open. Do this by clicking and dragging the file, then dropping it into the other window.
10) Verify that the UserKernel.app file now exists in the first window, the one showing the contents of your patched client.
11) Assuming everything is ok, close the first Finder window, then switch back to the second window, the one showing the contents of the install file.
12) Hit cmd+e to eject the disk image.

13) Open a new Finder window, navigate to your Applications folder, and open the game. It should now run.


Comment below rating threshold, click here to show it.

PlasmaBeam

Junior Member

05-08-2013

I have the same issue as iTzX.
It just won't login to the main server. Connection was correctly done (it worked up until a few weeks ago and no changes were done whatsoever), but I keep getting the same error:

Connection Error: Unable to connect to the PVP.net server

I have tried several possible solutions (Reinstalling, repairing, etc.) but to no avail. Ideas?


Comment below rating threshold, click here to show it.

Dataslave

Adjudicator

05-08-2013

Start a new thread specific to your issue, and post your system specs and logs, and I'll see what I can come up with.


Comment below rating threshold, click here to show it.

Cowchucker

Junior Member

05-25-2013

So I have been having this problem for quite some time. I'm a mac user and It won't allow me to join any game. Once I pick my champion it just says I'm in a game but I can't see anything and then I get a AFK penalty... I just got banned for three days. I'm pretty new and this kinda just ruined the game for me.


Comment below rating threshold, click here to show it.

Baxter900

Senior Member

05-25-2013

Quote:
Originally Posted by boevice View Post
My specific problem is I cannot even get to the loggin screen, I will click play and nothing will happy. League application will just close out.
This problem has to do with the userKernel being missing. Right click your application and click "show package contents". Then open contents ==> LOL ==> RADS ==> system. Check and see if UserKernel is there. It should also show the LoL logo as it's icon. If it isn't there or doesn't have the right icon then download the file here and replace it. If it looks alright I can't help you. This worked for me when I had this problem! Saved me a redownload.


12