No in-game sound

First Riot Post
Comment below rating threshold, click here to show it.

MMKH

Senior Member

03-01-2011

Hi, I've been using my Logitech G35 headset for a while now and used to get great sound while playing. However it seems that after today's patch that I am hearing absolutely nothing in-game. I can hear sound effects fine in the client and anywhere else though.

I have not changed my sound settings for the game and tried updating my audio drivers. Apparently it's not my computer's fault, but the game's.


Comment below rating threshold, click here to show it.

Vixen Fox

Senior Member

03-01-2011

I also have the G35 headset and am getting the same result.s

I'm also getting crash messages while loading.

The workaround for now is to set my headset to my default communication device, and my laptop speakers to my default device. This way, at least I get sounds out of the laptop speakers and I can still use my headset for mumble / skype.

PLEASE FIX LOGITECH G35 SUPPORT IMMEDIATELY! Perhaps it's something with positional audio?


Comment below rating threshold, click here to show it.

jaywatford

Lead Sound Designer

03-01-2011
1 of 1 Riot Posts

Hey guys,

We have an official thread up on this from Jesse Perring in 'Help & Support.' Here's a link:

http://www.leagueoflegends.com/board...d.php?t=553028

We're taking care of the issue right now and will be delivering a fix for it as quickly as we can. Until then, we suggest not using surround sound headphones, especially the G35. You can attempt to solve the problem by switching the headphone's audio configuration from 7.1 to stereo in your Window's control panel, though this may not be possible with the G35s. If you just turn surround sound off on your headphones and not your Windows settings it is far more likely the problems will persist.

Hold tight for a proper fix, if you have any questions before then I'd be happy to answer. Thanks for bringing this to our attention, you guys rock!


Comment below rating threshold, click here to show it.

MarioBauru

Junior Member

03-01-2011

same problem - no sound in "sound blaster audigy SE" - after load match (only this patch) 02/03/2011


Comment below rating threshold, click here to show it.

HollerCauster

Junior Member

03-02-2011

Thanks jaywatford!
Same Problem with the Sennheiser PC 333D Headset (also 7.1)


Comment below rating threshold, click here to show it.

DaGhost

Senior Member

03-02-2011

Quote:
Originally Posted by jaywatford View Post
Hey guys,

We have an official thread up on this from Jesse Perring in 'Help & Support.' Here's a link:

http://www.leagueoflegends.com/board...d.php?t=553028

We're taking care of the issue right now and will be delivering a fix for it as quickly as we can. Until then, we suggest not using surround sound headphones, especially the G35. You can attempt to solve the problem by switching the headphone's audio configuration from 7.1 to stereo in your Window's control panel, though this may not be possible with the G35s. If you just turn surround sound off on your headphones and not your Windows settings it is far more likely the problems will persist.

Hold tight for a proper fix, if you have any questions before then I'd be happy to answer. Thanks for bringing this to our attention, you guys rock!
I have no sound and I am using normal speakers


Comment below rating threshold, click here to show it.

Desmund Rughes

Senior Member

03-02-2011

Quote:
Originally Posted by DaGhost View Post
I have no sound and I am using normal speakers
I'm having this same problem. I have speakers and no headset. No sound and game crashes continually.


Comment below rating threshold, click here to show it.

14 to 17 Jews

This user has referred a friend to League of Legends, click for more information

Senior Member

03-04-2011

Has anyone had a similar problem crop back up after this last patch? I hear sound effects but they are just very very quiet in specific areas of the map, however, if i press space and recenter my camera the sound will come back up briefly then die away again (even if i hold the space bar). Voice and music is fine however, Very strange and not game-breaking but annoying. Granted i am on a mac, would post in that forum but im not sure that it is a mac specific issue


Comment below rating threshold, click here to show it.

Sentinel Beleg

Junior Member

03-04-2011

Quote:
Originally Posted by jaywatford View Post
Hey guys,

We have an official thread up on this from Jesse Perring in 'Help & Support.' Here's a link:

http://www.leagueoflegends.com/board...d.php?t=553028

We're taking care of the issue right now and will be delivering a fix for it as quickly as we can. Until then, we suggest not using surround sound headphones, especially the G35. You can attempt to solve the problem by switching the headphone's audio configuration from 7.1 to stereo in your Window's control panel, though this may not be possible with the G35s. If you just turn surround sound off on your headphones and not your Windows settings it is far more likely the problems will persist.

Hold tight for a proper fix, if you have any questions before then I'd be happy to answer. Thanks for bringing this to our attention, you guys rock!

No in-game sound no matter what device I use or settings.

Absolutely nothing i can do fixed the sound.


Comment below rating threshold, click here to show it.

MMKH

Senior Member

03-05-2011

Hmm, it seems my sound is working normally again, thanks Riot for the fix.