@RiotBrentMeister Client Patching "Freeze"

First Riot Post
Comment below rating threshold, click here to show it.

xXStaedtlerXx

Junior Member

04-27-2014

Fire wall step worked for me, also not sure if anyone else is getting this to but after I disabled my protection software my down speed went up to normal speed.


Comment below rating threshold, click here to show it.

Lazy LeBlanc

Junior Member

04-30-2014

Quote:
Originally Posted by Brentmeister View Post
Dannamoth has posted multiple times on this topic in this thread:
http://forums.na.leagueoflegends.com....php?t=4464105

I'll put my tech support hat on for a minute and try to suggest a few solutions that might get you playing. However, the most valuable thing you can do for us is gather your logs and post them in the thread above. Especially LolLauncher logs.

Okay please try these steps 1-by-1 and check if LoL works after each one. If one of the steps fixes it, it might be very helpful to know which one:
#0: Make sure that your hard drive isn't full (should have about 4GB of free space)
#1: Disable any anti-virus software you might have.
#2: Lets see if somehow your permissions got screwed up and you can't patch because you can't write the app bundle
Open up terminal and run this command: chmod -R a+rwx "Applications/League Of Legends.app"
#3: Try changing regions/languages in the patcher
#4: I know it's a pain but as a last resort, try deleting the application and re-downloading.

none of these have worked for me. I do not have firewall on and running the command in terminal gives me the answer it could not find League Of Legends.app


Comment below rating threshold, click here to show it.

Brentmeister

Associate Software Engineer

04-30-2014
3 of 4 Riot Posts

Quote:
Originally Posted by Dünnscheisser View Post
none of these have worked for me. I do not have firewall on and running the command in terminal gives me the answer it could not find League Of Legends.app
Ahh I think I know the problem.
Try running this slightly altered command. Also make sure you have installed League of legends in Applications
chmod -R a+rwx "/Applications/League of Legends.app"


Comment below rating threshold, click here to show it.

Lazy LeBlanc

Junior Member

04-30-2014

Quote:
Originally Posted by Brentmeister View Post
Ahh I think I know the problem.
Try running this slightly altered command. Also make sure you have installed League of legends in Applications
chmod -R a+rwx "/Applications/League of Legends.app"
Still not working, I have had the problem before and I fixed it by re-downloading League. It has not worked this time. I am currently checking if EUW server works. Is it just an NA server problem or on all of them?


Comment below rating threshold, click here to show it.

Lazy LeBlanc

Junior Member

04-30-2014

Okay, so I tried patching the EUW server and the exact same thing happens, stops at Archive_1.raf with 0 Kbps and 381 MB remaining. I really hope there will be a fix for this asap. What exactly is Archive_1.raf, since it seems to be the barrier of patching?


Comment below rating threshold, click here to show it.

mr smitty

Junior Member

04-30-2014

Having the same problem as Dünnscheisser. Still cant download even though i have done everything that has been suggested to do. New keyboard, mouse, and RP to use, please fix it soon riot


Comment below rating threshold, click here to show it.

Lazy LeBlanc

Junior Member

05-01-2014

This is so weird, yesterday evening I press the repair button and just leave it, then later it crashes. I close the mac. I woke up this morning and I open League and it's patched...


Comment below rating threshold, click here to show it.

GubernacuIum

Junior Member

05-02-2014

I have been having this problem for the last week and been trying to remedy this problem. I have no firewall, no virus software and before I have never had a problem with this.

I am running OS mavericks and have 150 gb free space. Did the terminal thing, did everything I can find to solve this problem and yet no solution has worked.

Anyone have any more suggestions?


Comment below rating threshold, click here to show it.

LuckyBags

Junior Member

05-03-2014

Quote:
Originally Posted by Dünnscheisser View Post
Okay, so I tried patching the EUW server and the exact same thing happens, stops at Archive_1.raf with 0 Kbps and 381 MB remaining. I really hope there will be a fix for this asap. What exactly is Archive_1.raf, since it seems to be the barrier of patching?
This.


Comment below rating threshold, click here to show it.

Brentmeister

Associate Software Engineer

05-05-2014
4 of 4 Riot Posts

Archive_1.raf is just the name of the first archive in any patch. I don't think it's significant to your problems, it just happens to be the first file so it's the file it errors on.

I'd recommend contacting player support by sending in a ticket. They can help see if it's a hardware problem or another process interfering with the patcher in a more personal 1-on-1 setting.

Otherwise, if you think it's an issue with the patcher submit your logs to dannamouth here:
http://forums.na.leagueoflegends.com....php?t=4464105
He's gotten a surprisingly low number of logs. Just make sure to use the send logs feature in the patcher and send the whole zip.

Also it's a pretty simple suggestion but make sure you reboot your computer and see if that fixes it. I had an issue with one of my PCs this weekend where I couldn't login (got maestro errors) and rebooting fixed it. Interestingly, it corresponded to problems I was having with my ISP.