Need technical help!

First Riot Post
123
Comment below rating threshold, click here to show it.

Katasumai

This user has referred a friend to League of Legends, click for more information

Senior Member

12-26-2013

Also to add when I did a little information fishing on Google I did find that multiple people tend to have problems with the Logitech K120 keyboard with other games as well and that they cannot replicate the problem with other keyboards but just that one keyboard. But yes please provide more info as if this occurred even before your mouse change out.


Comment below rating threshold, click here to show it.

Artyom Vexis

Senior Member

12-26-2013

Quote:
Originally Posted by Katasumai View Post
Hm, alright then.

What else is running when you are using your LoL Client with the keyboard and mouse?

I'm sure you've tried a reboot.

How old is the keyboard? Did it give you any issues with any other mouse before hand?

Have you tried (and I know this will suck) re-installing/bug fixing your LoL client before you hit the play button?

If you have anymore info you can provide, please feel free to post it so I can keep getting more information.

~Katasumai
Google Chrome with my FB tab, Razer Comms, and Razer 2.0 if I'm changing settings.

Yes, I have.

Keyboard isn't that old, it's a K120, built for Win8.

Yaeh, I have. Still nothing. x.x


Comment below rating threshold, click here to show it.

Katasumai

This user has referred a friend to League of Legends, click for more information

Senior Member

12-26-2013

Quote:
Originally Posted by Artyom Vexis View Post
Google Chrome with my FB tab, Razer Comms, and Razer 2.0 if I'm changing settings.

Yes, I have.

Keyboard isn't that old, it's a K120, built for Win8.

Yaeh, I have. Still nothing. x.x

Try disabling your keyboard and re-enabling it, or even should be able to scan for issues in your computers hardware info.


Comment below rating threshold, click here to show it.

batosia95136

This user has referred a friend to League of Legends, click for more information

Senior Member

12-27-2013

OK I know this is old but I'mma follow up regardless. The ports in the back that don't work, are they USB 2.0 or 3.0?

I know some mobos have really annoying issues with USB3.0.


123