OS X Mavericks Bug

First Riot Post
Comment below rating threshold, click here to show it.

PARTH183

Senior Member

10-22-2013

Hey so I downloaded the new Mac OS today and the game isnt running that well on it. Im getting a constant 30 fps while before i used to get a steady. Since the software update on my computer i havent changed any league settings. is there something wrong with the compatibility of the client and the new OS? Im guessing it has something to do with the new AppNap feature in Mavericks. Would be nice to get some responses or a fix hopefully. Anyone else having this issue?


UPDATE: So i have tried running it with enerysaver off and V-Sync off and the problem still persists. Another user mentioned that the problem is affecting refurbished macs, mine is refurbished so that might be the problem. Although i dont see how it affects anything because my spec are easily high enough to run the game at 60FPS, as i had been doing before the os update.

Guys please help its really frustrating to have to play at 30fps when your pc has hardware that can run it at almost on full resolution. I currently have it on medium and its giving me these problems. I even get lag spikes that randomly drop me to 5-10 fps.

Also in activity monitor its showing the "UserKernel" as not responding

FIX FOUND: So apparently the fps returns to normal if you change the window mode from full screen to borderless in the video setting. A big thank you to @MrFungb for figuring this out. Thanks a lot man i can play at 60FPS again

Attached Images
File Type: jpg League Activity Monitor.jpg (66.6 KB, 836 views)

Comment below rating threshold, click here to show it.

puremojo

Senior Member

10-22-2013

how old is your computer?

youre the first ive seen say this. I have a mid 2011 mbp, im testing league right now so ill post later on OS X Mavericks thread what my findings are


Comment below rating threshold, click here to show it.

PARTH183

Senior Member

10-22-2013

I have the mid 2012 15" retina


Comment below rating threshold, click here to show it.

puremojo

Senior Member

10-22-2013

try repairing disk. I just tested my older one and i had a huge performance boost.

also make sure anti-aliasing is off


Comment below rating threshold, click here to show it.

PARTH183

Senior Member

10-22-2013

come on guys i cant be the only one this is happening to....


Comment below rating threshold, click here to show it.

TeclaT

Member

10-22-2013

yea i have the same problem, I have the original retina macbookpro


Comment below rating threshold, click here to show it.

Brentmeister

Associate Software Engineer

10-23-2013
1 of 1 Riot Posts

Try disabling V-Sync in the video options and see if that resolves your issue.


Comment below rating threshold, click here to show it.

lJoSquaredl

Junior Member

10-23-2013

Kinda worried about installing Mavericks. I have a rMBP from 2012 as well. Always iffy about updates I usually wait a few weeks, but the full screen monitor tweak is calling my name I play LoL at 900p on all very low settings tho, don't know how I could possibly see a performance hit at that low of settings, altho I do prefer v-sync on cuz it looks shifty when I dont use it in games. Also what happened to 30fps? Now it's 60fps or uncapped. I don't mind 30fps cuz I play console and frankly my computer doesn't even get warm at 30fps


Comment below rating threshold, click here to show it.

DericDraco

Junior Member

10-23-2013

Had the lag spikes & performance issues before Maverick. Installed Maverick hoping it would fix the lag, same issues. Everything happened after the setting menu changed/re-work.

~Draco
MBP 15-inch, Mid 2010
2.4 GHz Intel Core i5
8 GB 1067 MHz DDR3
NVIDIA GeForce GT 330M 256 MB


Comment below rating threshold, click here to show it.

Arhida

Junior Member

10-23-2013

Prior to upgrading to Mavericks I was getting constant 60 fps capped there and no issues. Since installing, I'm having random instances of FPS dropping to 30ish and locking the game up quickly before returning to normal. This happens every couple of minutes. I've tried turning off shadows, v-sync, borderless window mode etc. Nothing.

I'm using an iMac:
Running at Very High, shadows off, 2560x1440.
3.4 GHz i7 Quad
Graphics NVIDIA GeForce GTX 680MX 2048 MB
and 16 GB of RAM