New Mac, but Champ Loading takes forever?

Comment below rating threshold, click here to show it.

President Obama

Junior Member

05-29-2013

New Mac, but during the loading screen (Splash etc), I usually get to like 20% and then freeze (everyone else's loading bar freezes too), and after a few minutes, it all goes very fast to 100%, waits a bit at 'Summoning' and then everyone will start the game, and I will too but after a few seconds. First few seconds in game is also very low FPS but it gets better later. Any help? (When I click Energy Saver, there's no Graphics option)
Thanks in advance.


Comment below rating threshold, click here to show it.

chungkysoup

Junior Member

05-29-2013

same here


Comment below rating threshold, click here to show it.

Dataslave

Adjudicator

05-29-2013

Post your system specs, and all of your video settings, and perhaps we can offer a few recommendations.


Comment below rating threshold, click here to show it.

President Obama

Junior Member

06-03-2013

Processor - 2.5 GHz Intel I5
Memory - 4 GB 1600 MHz DDR3
Graphics - Intel HD Graphics 4000 512 MB
Software - OS X 10.8.2

Same problem as this guy: http://na.leagueoflegends.com/board/....php?t=3466458


Comment below rating threshold, click here to show it.

President Obama

Junior Member

06-06-2013

Bumping, still a huge problem + another related problem.
When it crashes in loading (Maestro etc), I have no option to reconnect, and when I close client (the popup says League of Legends is now attempting to exit), nothing happens and I have to -> Activity Monitor and Force Exit.

And the load still takes ages. It will freeze at a certain percent, and after a while (just then I timed it.. 3 minutes) it will go really quick up to around 90-99% and hang, then Summoning, and around 20 seconds later I join the game with 10fps, which balances back to normal over the next 10 seconds.

Really annoying for ranked teams, when I can't join any invade. Thanks for any help


Comment below rating threshold, click here to show it.

Dataslave

Adjudicator

06-06-2013

Run software update, I vaguely recall a random network issue with lol in 10.8.2 that got fixed in later releases.

What video settings are you using? Have you tried dialing everything down to the lowest possible (including resolution), disabling vsync, and setting frame rate cap to benchmark? This will produce the highest possible framerate, and I'm curious if you still have the giant framerate drop at the start of games with low settings on.


Comment below rating threshold, click here to show it.

President Obama

Junior Member

06-09-2013

Sorry for the late reply.
I updated my OSX to 10.8.4. I found the latency issue was due to connection issues, but the FPS/extremely long load is still persistent. The main thing I find is that my loading will freeze (and I can't tab out) but after a while my cursor turns to the In Game "Hand" cursor and then my loading goes crazy fast.

My video settings are all "Low" and Benchmark frame rate cap - I've noticed an improvement in my FPS when the game begins ('Welcome to Summoenrs Rift' etc) but the loading is still a pain.
Any other ideas? Thanks for the help


Comment below rating threshold, click here to show it.

Avatar Aang DuMa

Junior Member

06-24-2013

Exact same problem here.
Specs:
MacBook Pro 13 inch Early 2011

Mac OSX Lion 10.7.5 (11G63b)
Processor: 2.3 GHz intel core i5
4GB 1333 MHz DDR3 Memory
Graphics: intel hd graphics 3000 384 MB

And I have everything on low, no vsync and benchmark fps.
Although, it's mostly the first game when I open the game that has the early game 2 fps lag. The rest including slow loading screen, the cursor disappearance and freezing loading bar/screen is there.

I've found that as soon as the loading screen comes out, I minimized by alt tabbing and come back to game itself only when I hear the start of game sound, it seems to be faster, although I'm not entirely sure. However, if I constantly alt tab back from the game and my desktop to check if the game has started, it will load/freeze FOREVER.