Graphics bug after pre-season patch

First Riot Post
12345612 ... 15
Comment below rating threshold, click here to show it.

CFlyHigh

Member

12-04-2012

ok so i just tried the patch repair thing, and now i cant even play anymore the client just crashes... trying to redownload the game now


Comment below rating threshold, click here to show it.

Ninja Boss91

Member

12-04-2012

This is bugged on my lvl 30 account, i made a new account for the hell of it, played bot caitlyn and no glitches at all...go back to 30 and its glitched....makes no sense


Comment below rating threshold, click here to show it.

RainbowSensation

Member

12-04-2012

Same issue. My initial thoughts is that it's due to an outdated graphics card? However I struggle to update mine...
Help with this bug would be well... helpful.


Comment below rating threshold, click here to show it.

Dannamoth

QA Analyst

Follow Dannamoth on Twitter

12-04-2012
1 of 10 Riot Posts

Okay, the first thing you will want to do is update your drivers for your graphics card. Also, if everyone who is having this issue can post their DxDiag file to this thread that would be helpful in figuring out if this is related to a specific GPU.

To get a Dxdiag: https://support.leagueoflegends.com/...stic-or-dxdiag


Comment below rating threshold, click here to show it.

BoxenOfKittens

Junior Member

12-04-2012

yeah happens to me too and when i open the store, chat box or my stats too. I tried re-installing and repairing to no avail...


Comment below rating threshold, click here to show it.

RainbowSensation

Member

12-04-2012

Okay I attempted to update my graphics card this morning but couldnt find all the information required about my laptop lol :L

So this dxdiag is with updating my graphics card or anything. I'll have another attempt at doing it now.

Thanks for the red post.


Comment below rating threshold, click here to show it.

Ninja Boss91

Member

12-04-2012

Here's mine, seems the same as his, :/


Comment below rating threshold, click here to show it.

Dannamoth

QA Analyst

Follow Dannamoth on Twitter

12-04-2012
2 of 10 Riot Posts

It looks like it's an issue specific to this particular graphics chip: ATI Mobility Radeon HD 5650

Could you guys try loading into a custom game and reducing your graphics settings to all very low? In addition try disabling shadows. I want to see if their is a work around for the short term.

Also, try disabling your graphics adapter and use the intel integrated graphics (should be HD2000 or HD3000). If that runs the game it would verify that it is an issue specific to the ATI GPU in your machine.


Comment below rating threshold, click here to show it.

CFlyHigh

Member

12-04-2012

my graphic cards is ATI Radeon HD 4650, and i cant even set the graphics anymore, now my client crash 5 sec after im in the game

now that i managed to reduce all the video settings to low, the background is still glitched when i open tabs


Comment below rating threshold, click here to show it.

Dannamoth

QA Analyst

Follow Dannamoth on Twitter

12-04-2012
3 of 10 Riot Posts

Quote:
Originally Posted by CFlyHigh View Post
my graphic cards is ATI Radeon HD 4650, and i cant even set the graphics anymore, now my client crash 5 sec after im in the game

now that i managed to reduce all the video settings to low, the background is still glitched when i open tabs
Could you post your Dxdiag file? I would also recommend updating your video card drivers to the latest version. This has been resolving issues for multiple people using ATI cards.


12345612 ... 15