Europe vs US Servers - Choice Missing

First Riot Post
Comment below rating threshold, click here to show it.

grillbiff

Junior Member

09-25-2010

Main Issue:
Europe vs. US servers, LoL application should offer a choice of where to log in. It doesn't now.

Secondary Issues:
First-time launch-install is super slow, confusing and lacks pertinent info for the user.
Chicken and egg problem on first install needs a mechanism to report the problem in the first place that doesn't have the current restrictions on the leagueoflegends.com site (forum, etc..) that keep Riot blind.
"Quit" command does not work on a Mac (cardinal sin for Mac users), it's either ignored, missing or mislabeled in different parts of the process to launch LoL.
--
NOTE: One day later (after this e-mail was sent) the program patched and worked properly but this was my original experience on the first day I tried to enter the beta, installing in a brand-new iMac. If this were *not* a beta this would mean phone call + e-mail to "Support" at Riot Games, which is equal to spending money on Support or alienating users for lack of support. Either way this process should change and be fixed to either lower support costs or avoid them altogether and keep users positive.
--
---
Sent: Tuesday, September 21, 2010 8:46 AM
Subject: Re: (for Riot Games) Mac Beta request

Thanks for the invite, looking forward to helping out.
First, I ran into a problem... Well, to begin with I can't log-in.

I had originally created an account in Europe (I'm in Sweden) before I contacted you.
After that failed to log-in with the beta client, I figured that Europe won't work with the beta client, so I created an account in North America.
That won't work either, no idea why. Login screen comes up in the client but it displays an alert
"Connection Failure: Unable to connect to the PVP.net server."
with an OK button that quits immediately when pressed.

The web site won't let me log-in until I've created a summoner but the client won't accept my login name and password in order to create one. No idea why.

So I can't start the game.

Second issue is that application version "1.0.4559 (1)" won't Quit on the Mac.
It doesn't quit with the menu, it doesn't quit with anything I try except "Force-Quit" from the Activity Monitor.

Third issue is that I can't log-in to your forum link to post bugs because it asks for login and password,
which won't work because I haven't created a summoner, "You must first create a Summoner by logging into League of Legends before logging into our website",
which won't work because I can't log-in via the client. < sigh >

Maybe I'm missing something. Is there something I have to do for the "PVP.net" patcher you mentioned on Mac or is that automatic?

<image: "Connection Failure: Unable to connect to the PVP.net server. >

Also, the first launch took forever and it's not clear in the progress dialog what it's doing or how much is left.
Both bars fill up to the maximum before the next phase starts over so it's difficult to know what's up.
Eventually the "Play" button lights up but until then, one is pretty much in the dark.

Last thing is that minimizing the window when you "Play" is just weird. Next time you launch it flies at you from the Dock which is really strange, probably because it's a background application. "hide" would be more normal, instead of minimize. It's also odd that there is no Quit button in that window, since it has no interface other than what the window displays (it's a background application).
There really ought to be a Quit button on that thing somewhere because there is no menubar to select a "Quit" item.

<image: "Server Status: UNAVAILABLE" >



-- Brand New iMac --
Hardware Overview:

Model Name: iMac
Model Identifier: iMac11,2
Processor Name: Intel Core i5
Processor Speed: 3.6 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache (per core): 256 KB
L3 Cache: 4 MB
Memory: 4 GB
Processor Interconnect Speed: 6.4 GT/s
Boot ROM Version: IM112.0057.B00

ATI Radeon HD 5670:
Chipset Model: ATI Radeon HD 5670
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: ATI (0x1002)
Displays:
iMac:
Resolution: 1920 x 1080
Pixel Depth: 32-Bit Color (ARGB8888)


Comment below rating threshold, click here to show it.

erik4ever

Junior Member

09-26-2010

Ok I found a solution.


You need to edit the LoL Package and find the lol.properties in /Applications/League of Legends.app/Contents/Resources/transgaming/c_drive/rads/projects/mac_lol_air_client/releases/0.0.0.7/deploy/LolClient.app/Contents/Resources


Edit lol.properties and replace :

host=beta.lol.riotgames.com
xmpp_server_url=beta.lol.riotgames.com


by :

host= prod.eu.lol.riotgames.com
xmpp_server_url=chat.eu.lol.riotgames.com

I found a second lol.properties in /Applications/League of Legends.app/Contents/Resources/transgaming/c_drive/rads/projects/lol_air_client_config_na/releases/0.0.0.0/deploy

I edited it too, but I think its useless.


You're welcome


Comment below rating threshold, click here to show it.

Udyr

eCommerce Manager


Follow Udyr on Twitter

09-26-2010
1 of 1 Riot Posts

The reason you weren't able to login because the servers were unavailable, as was show in the launcher.

We are currently working on making the launching process on the Mac more smooth; thanks for the feedback.