League of Legends Community
12

League of Legends Community (http://forums.na.leagueoflegends.com/board/index.php)
-   Mac Client (http://forums.na.leagueoflegends.com/board/forumdisplay.php?f=31)
-   -   Main Menu - SSL Certificate invalid (http://forums.na.leagueoflegends.com/board/showthread.php?t=3356674)

AdNoctem 04-19-2013 02:19 PM

Main Menu - SSL Certificate invalid
 
Switched to the store after loading client and got this message, haven't tried to repeat as I am ignant.

tuxedobob 04-20-2013 10:46 PM

Same here. It's probably safe to continue anyway, though.

Benhameen 04-21-2013 09:12 AM

Here are screenshots of the error window:

https://dl.dropboxusercontent.com/u/...riot_ssl-1.png
https://dl.dropboxusercontent.com/u/...riot_ssl-2.png

inseinik 04-24-2013 06:13 AM

bump

Brentmeister 04-25-2013 01:41 PM

It looks like the DigiCert certificate chain is not trusted. However, I'm not getting this error. What version of Mac OSX are you guys using?

StAquinas 04-25-2013 05:26 PM

I have the same error in the shop on OSX 10.6.8.

I also notice that the "UserKernel" Application that opens as one of the 3 league related programs (UserKernel, LolLauncher, LolClient) is never responding, from the moment I first start to when I close and even during games.

Dataslave 04-25-2013 08:56 PM

2 Attachment(s)
I had this happen once on the PBE, and it went away within a few days. *shrug*.

*edit*

I dug up the screenshots from when it happened.

Benhameen 04-29-2013 08:58 AM

Quote:

Originally Posted by riotbrentmeister (Hozzászólás 37085846)
it looks like the digicert certificate chain is not trusted. However, i'm not getting this error. What version of mac osx are you guys using?

10.8.3

Dataslave 04-29-2013 09:06 AM

The issue seems to crop up from time to time on both platforms, so I don't think its worth worrying about here. The only thing you can really do is if you persistently get the certificate error is your system time/date, and if that's fine, just go ahead and approve the certificate manually.

- http://na.leagueoflegends.com/board/....php?t=3358895
- http://eune.leagueoflegends.com/boar...d.php?t=402557
- http://euw.leagueoflegends.com/board...d.php?t=203726
- http://na.leagueoflegends.com/board/...d.php?t=761481
- http://eune.leagueoflegends.com/boar...d.php?t=204709

Dozens more.

Whipblade 12-26-2013 04:59 PM

Ran into this issue tonight. Was able to locate the intermediate certificates that are required for the certificate to be trusted. You can find them here: https://www.digicert.com/digicert-root-certificates.htm

Look for these two:
- DigiCert Secure Server CA
- DigiCert High Assurance CA-3

Download and install them. They come pre-installed on all modern browsers and mobile devices, but it's possible that they can get deleted. Once we installed them - boom, up and running again. Hope this helps someone out there!


All times are GMT -8. The time now is 06:03 AM.
12


(c) 2008 Riot Games Inc