League of Legends Community
123

League of Legends Community (http://forums.na.leagueoflegends.com/board/index.php)
-   Mac Client (http://forums.na.leagueoflegends.com/board/forumdisplay.php?f=31)
-   -   League of Legends will not open [FIX!] (http://forums.na.leagueoflegends.com/board/showthread.php?t=3334994)

RSisCOOL 04-13-2013 03:53 AM

League of Legends will not open [FIX!]
 
Hey guys this is just a thread for anyone else that experienced this problem that i had.

Basically the game just wouldn't open you click the icon just bounces then goes away or similar to that so anyway after 4 days of scanning the forums for a damn solution i finally found one... i take no credit for this solution at all.

From Swizzy92
http://na.leagueoflegends.com/board/...3190671&page=4

original thread ^

quote from him

Ok I fixed my original LoL client that wouldn't open.

Basically I downloaded the original .dmg file, open it, drag it into application folder.
Now, DON'T overwrite your original LoL app. You should have League and League (2).
Open package contents of League (2)
Now: Contents
LOL
RADS
system
Now, for me, UserKernel was the problem. Your original League UserKernel file should have one of those paper/pencil icons instead of the league icon, meaning that somewhere along the line the UserKernel file got changed (IDK). Basically, drag and overwrite the UserKernel from League (2) onto your original League package and overwrite, which will change the icon as well.
Upon boot, splash icon for original league will now open and game will open as normal.

I followed these instructions to some point, instead what i did was go into my download folder open up the League of Legends.dmg the one that opens the LoL icon and applications, right click the icon "show contents"
navigate to said directory ^

contents/LOL/RADS/system/ and then DRAG "UserKernel" from the dmg in your downloads or where ever you have opened it etc and replace the previous userkernel with that new one and it should run perfectly, in my case i didnt even have UserKernel for some reason it dissapeared not sure if my fault or not, but that is the solution to league of legends not launching at all please sticky or something to save other players from scanning forums for a week and giving up...i was near giving up till i found that 4 days of scanning google, forums etc it would be good to have a riot post about this or something similar thanks :)

Baxter900 04-19-2013 07:57 PM

Riot please pin, it works!!!

And thank you for saving me from hours of reinstalling!

RSisCOOL 04-21-2013 02:08 AM

Quote:

Originally Posted by Baxter900 (Hozzászólás 36899898)
Riot please pin, it works!!!

And thank you for saving me from hours of reinstalling!

glad i could help mate

RSisCOOL 04-26-2013 02:13 AM

bump.

the treekicker 04-26-2013 07:41 AM

Awesome thanks it worked!

although for me, my user kernel had been entirely deleted during the league repair fix.

GenXen 04-26-2013 01:18 PM

I have a similar problem but my UserKernel is the league icon. Anything else I should look for ?

RSisCOOL 04-27-2013 04:40 AM

Quote:

Originally Posted by GenXen (Hozzászólás 37116423)
I have a similar problem but my UserKernel is the league icon. Anything else I should look for ?

im not too sure what you mean but try this im sure this is your problem


open up downloads, or whatever you store your downloaded files in, open up the league of legends disk image, itll show the league icon and the applications folder also dont worry about the app folder though just right click on the LoL icon show contents then go
Contents/LOL/RADS/system and youll fine a new UserKernel simply open up your normal league folder in applications or where ever you store it then navigate to the same directory and simply drag the icon in and the game will boot up straight away.

or.. you could just replace your entire league folder but then you will require patching etc so yeah

hopefully you can understand my informal instructions :p thanks

swadedaf 05-21-2013 02:44 PM

i have the same problem as GenXen, where my userkernel is in the folder with the League icon! i've tried replacing it from the userkernell that's in the .dmg but it still wont work

MrMany 05-28-2013 10:09 PM

it happen me too...

guys can someone of you share with me your userkarnel? because its happening to me and is the first time I've installed LOL on MAC so i dont have an old file.

Winged Rob 05-31-2013 05:48 PM

I find myself in the same situation as mmany. This is my first install of the client, and therefore I have no old user kernel to copy. Is it possible that this single file be made available so that we can grab a functioning version and correct our faulty install?

PS: I downloaded it multiple times in hopes of getting a working version - no dice.


All times are GMT -8. The time now is 05:16 AM.
123


(c) 2008 Riot Games Inc