League of Legends Community
12345 ... 11

League of Legends Community (http://forums.na.leagueoflegends.com/board/index.php)
-   Bug Reports (http://forums.na.leagueoflegends.com/board/forumdisplay.php?f=3)
-   -   Failed to Connect (http://forums.na.leagueoflegends.com/board/showthread.php?t=2180176)

Saint1y 06-03-2012 09:16 AM

Failed to Connect
4 Attachment(s)
In the middle of a match, the game crashed. I can reopen the LoL launcher without a problem. It then presents the reconnect to game button. When I tried to log back in, it tells me 'Failed to Connect: Unable to connect to server. If you have a firewall, it may be blocking the connection. please refer to your firewall's documentation. Would you like to retry the connection?'

Nothing changed on my computer from the moment I was playing to the moment I got that message. Adding an exception to the firewall and turning off the firewall did not resolve the problem.

This is the first time I have received this message. I am unable to play at all due to this problem.

Attachment 452901

Attachment 452902

Attachment 452903

Attachment 452904

Leptospira88 06-03-2012 09:23 AM

1 Attachment(s)
I'm having the same issue. I was in a dominion game and the entire game crashed. Now It keeps asking me to reconnect to the server when I log in but then it is unable to connect.

Anonymys 06-03-2012 09:29 AM

Same issue here - randomly dc'd in a normal bot game. Cannot reconnect. Firewall adjustments do nothing.

Goodmilk 06-03-2012 09:40 AM

same here :X

g0dsinclair 06-03-2012 06:44 PM

same thing here!
I play one game fine and then the very next game I get the error...so go ahead and tell me its my firewall all of a sudden...go ahead, lie to me

did i mention that i can still join my own custom games?

Lextirpate 06-12-2012 02:27 PM

My roommate and I are also getting the issue (even when only one of us is trying to play). What's going on here, Riot? Please fix this.

To be specific, after everyone's locked in and the countdown finishes, the "LEAGUE of LEGENDS" splash screen appears. It stays there for a very long time. If I mouse over it, my mouse cursor turns into the circular "loading" cursor. Eventually, it makes a Windows ding sound and a window appears behind it (because the splash screen is set to "always on top") with the title, "Failed to Connect", and the text, "Unable to connect to the server. If you have a firewall, it may be blocking the connection. Please refer to your firewall's documentation. Would you like to retry the connection?". It has a "Retry" button, a "Cancel" button, and the standard Windows "X" button in the top-right corner. If I click "Retry", the window disappears and the splash screen remains, repeating the cycle. If I kill all the LoL-related processes using Process Explorer and try logging in again, sometimes it allows me in and gets to a loading screen and sometimes it doesn't, preferring to do the same thing with the splash screen and eventually "Failed to Connect" window. Please fix your network and loading code.

I am a network administrator and I understand what a firewall does. I have Windows 7's firewall disabled. I am using a Billion BiPAC 7800N gigabit router (said to be among the most stable and consistent routers in existence) set to forward all ports to all machines on my LAN (default setting). LoL worked perfectly and consistently until yesterday when I first saw this issue. None of my hardware or software changed between the time it worked consistently and when I first started seeing this issue.

I live in Toronto, Ontario, Canada and my ISP is Acanac. I have their 28 Mbps cable internet plan. Acanac uses the Rogers network for its cable connection to my home. Acanac is also somehow related to Distributel, but I'm not sure in what way.

Lextirpate 06-13-2012 12:06 AM

Why is this thread buried by other threads? The above problem is still happening. It takes me 5-20 attempts at reconnecting at the beginning of every game! Often, I only get in after the enemies are already level 3-5! This needs an immediate hotfix.

Please note that once the loading screen itself loads, everything works perfectly. My ping is normal (~100 ms). My UI is normal (no flickering). It's just that I have to repeatedly kill all the LoL-related processes (WHY ARE THERE 4!?) and restart LoL so I can quickly retry connecting.

Lextirpate 06-13-2012 04:07 PM

New information: I can consistently connect if I wait for the splash screen to time out, click "retry" once, wait until it times out again, then click "retry" again. So, something about the third connection attempt is working. Please make the first connection attempt do whatever the third connection attempt does. Also, this problem is still ongoing and it is major.

Armoredmando 06-14-2012 10:52 PM

I'm having the same issue, running on a mac OSX, please help

Lextirpate 06-14-2012 11:41 PM

This is still happening. Please fix it with high priority.

All times are GMT -8. The time now is 03:20 AM.
12345 ... 11

(c) 2008 Riot Games Inc