League of Legends Community

League of Legends Community (http://forums.na.leagueoflegends.com/board/index.php)
-   Mac Client (http://forums.na.leagueoflegends.com/board/forumdisplay.php?f=31)
-   -   Whole computer crash on B (http://forums.na.leagueoflegends.com/board/showthread.php?t=3347524)

PixarFan 04-16-2013 08:14 PM

Whole computer crash on B
 
MacBookPro5,1
Intel Core 2 Duo 2.4 GHz
4GB
nVidia GeForce 9600M GT
OSX 10.8.3

Press B key to return to base and as the rings appear, the whole computer screen becomes black and system crashes. OSX then reboots.

This can be duplicated without fail.

If I switch to the integrated GPU (nVidia GeForce 9400M), the system doesn't crash and I can return to base just fine. However, playing with the 9400M means my framerate drops by half and I can't choose a higher graphics setting.

PixarFan 05-03-2013 07:32 AM

I'm still having this problem with the latest 3.6 patch. However, I can't get it to consistently crash as in 3.5. In 3.5, as soon as I press the B button, I see the blue rings and it will always crash. In 3.6, I can play the game normally for a while, but it will randomly crash.

In both cases, the crash is the grey Mac OSX screen which tells me the system will have to restart and the whole system shutdowns and reboots. I've shutdown all other apps and 3rd party utilities and I still crash.

LOL is the only app that actually crashes my Mac like this and still only when I use the discrete 9600M GPU. The integrated 9400M GPU doesn't crash (but obviously runs at half the frame rate). StarCraft 2 Mac beta had a similar crash but they fixed it.

Dataslave 05-03-2013 11:12 AM

Have you tried repairing your client, or reinstalling lol?

PixarFan 05-08-2013 11:14 AM

Just tried reinstalling today and I still experience this problem.

Dataslave 05-08-2013 02:20 PM

At this point you're probably stuck. If they can replicate the issue internally on the same hardware, then its something they can fix. If nobody can reproduce the issue, then its probably a problem with your computer.

About the only thing I can think of (short of performing an OS reinstall on the faint chance its not hardware related) is to try a SMC reset.


All times are GMT -8. The time now is 04:45 PM.


(c) 2008 Riot Games Inc