League of Legends Community

League of Legends Community (http://forums.na.leagueoflegends.com/board/index.php)
-   Help & Support (http://forums.na.leagueoflegends.com/board/forumdisplay.php?f=15)
-   -   Ports forwarded but still not open. Game crashes and internet hiccups observed. (http://forums.na.leagueoflegends.com/board/showthread.php?t=2829723)

Prateem 11-22-2012 06:53 PM

Ports forwarded but still not open. Game crashes and internet hiccups observed.
 
So I've forwarded the correct ports from my router config page Linksys/Cisco (WRT160Nv3) and have enabled all of the port-forwarding rules. When I go to check if the ports are open using http://www.firebind.com/test/lol, the test reports failure for both UDP and TCP port types and causes my internet to have a sort of hiccup (says it's connected fine but chrome has trouble displaying web pages, skype disconnects and attempts to reconnect, pidgin does the same, etc).

The big issue with this is that the same things that happen (when I try to check the ports via firebind) will happen if I'm in the loading screen of a LoL game -- every game; it causes me to disconnect and subsequently crash in the loading screen over and over until I get lucky and it doesn't disconnect+crash me. It really sucks. I've resolved myself to not sit through another bout of frustration in regards to this issue until I can know that this is fixed.

It doesn't even seem to be a port issue of any sort, since I can confirm that the ports League uses are open and available.

My DXDiag can be found here: https://www.dropbox.com/s/vwxzm1ux09n5zhn/DxDiag.txt

Prateem 11-22-2012 11:12 PM

Bump.

Prateem 11-23-2012 11:50 AM

Bump.

Postal Twinkie 11-23-2012 11:51 AM

Your ISP very well could be blocking ports, why they would block the ports LoL uses is beyond me. Run this test and post the results URL...

http://netalyzr.icsi.berkeley.edu/

Prateem 11-23-2012 01:14 PM

http://n3.netalyzr.icsi.berkeley.edu...21df-40f9-ac16

Here's the netalyzr result (ran a few days ago but nothing's changed since then). Thank you for the response and attention to my issue. It is very much appreciated!

Postal Twinkie 11-23-2012 01:21 PM

Your ISP is blocking port 5060, LoL game client uses ports from the 5000 to 5500 range. It might be possible that your ISP is also blocking more ports than what the test shows, as it doesn't test every port.

Who is your ISP? Is it a smaller private company?

EDIT: I say your ISP is blocking them as it sounds like you have already enabled all the Port Forwarding you can enable on your end, leaving your ISP as the only other option.

Prateem 11-23-2012 01:25 PM

I should add that this issue hasn't been existant for the large majority of my time playing LoL. It only popped up within the recent two patches. Very rarely in the final patch of S2 and every game except for the rare games where I have no issues in the pre-season patch.

My ISP has been consistent throughout my time playing LoL, as well. Just providing as much information as I can. I can post r3d logs of some games where this has happened too.

Here are some logs for a batch of connect attempts from two or three nights ago.

4:23 AM - http://pastebin.com/FCGXTyLr
4:24 AM - http://pastebin.com/kH1ef1au
4:25 AM - http://pastebin.com/6BnUAwb4
4:26 AM - http://pastebin.com/0pJb9wuj -- This is where it gets more interesting.
4:27 AM - http://pastebin.com/nyg1Z7LS -- Still interesting.
4:28 AM - http://pastebin.com/XEdAw7Rr -- Stiiill interesting.

Prateem 11-23-2012 01:27 PM

My ISP is Voice Network (Canadian). I believe they are a smaller private company. It used to be Yak Residential Internet but Voice Network acquired Yak's residential internet services a while ago. It was long enough ago that it didn't pose any issues with my gameplay. Maybe they've changed some settings since. Are there any other possibilities? I will be sure to give my ISP a call but I just want to make sure.

Postal Twinkie 11-23-2012 01:30 PM

Post your Netlogs.

Prateem 11-23-2012 01:31 PM

Oh whoops wrong thing. The netlogs from the log folder are all blank. 0 Kb and absolutely empty.

When I check my logs, I see a whole bunch of absolutely empty netlog .txt files for 4:23 - 4:28 AM (one for every minute) wherein I was trying to reconnect successfuly to the game and make it past the loading screen via exiting the client and restarting.


All times are GMT -8. The time now is 11:23 PM.


(c) 2008 Riot Games Inc